Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some time ago, I upgrade my FreeBSD box to 7.1-RC2, but now I'd like to move to 7.2-RELEASE. I tried running

# uname -mrsi
FreeBSD 7.1-RC2 i386 GENERIC
# freebsd-update upgrade -r 7.2-RELEASE
Looking up update.FreeBSD.org mirrors... 3 mirrors found.
Fetching metadata signature for 7.1-RC2 from update4.FreeBSD.org... failed.
Fetching metadata signature for 7.1-RC2 from update5.FreeBSD.org... failed.
Fetching metadata signature for 7.1-RC2 from update2.FreeBSD.org... failed.
No mirrors remaining, giving up.

Substituting 7.1 for 7.2 gives the same error. Adding a --debug option shows the failure as being

fetch: http://update4.FreeBSD.org/7.1-RC2/i386/latest.ssl: Not Found

Is there any way to still do a binary upgrade of this system as the 7.1-RC* directories don't exist on http://update.freebsd.org anymore? Upgrading from source is an option, but I wanted to see if there was some way to salvage this installation.

share|improve this question
1  
Is there some reason a source upgrade is not an option for you? I don't think there's a graceful way for you to do a binary upgrade at this point. –  Geoff Fritz Nov 25 '09 at 18:41
    
Bummer. Go ahead and propose this as a solution. Thanks! –  ctuffli Nov 27 '09 at 3:57

1 Answer 1

up vote 0 down vote accepted

from the freebsd-update manpage of 7.1:

 Note that updates are only available if they are being built for the FreeBSD 
 release and architecture being used; in particular, the FreeBSD Security Team
 only builds updates for releases shipped in binary form by the FreeBSD Release 
 Engineering Team, e.g., FreeBSD 6.1-RELEASE and FreeBSD 6.2-RC1, but not 
 FreeBSD 6.2-STABLE or FreeBSD 7.0-CURRENT.

it seems the answer is "no".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.