Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently set up an ArchLinux system at work and added the ArchHaskell repo. This is far from the first time I do this. I have a number of systems where it's worked just fine, but this last time it did not. The signed repo database file, which is a gzipped tar-ball on the server, arrives as a straight tar-ball on my system. This of course prevents pacman's signature checking.

The strange this is that the other repo databases, e.g. [core], do arrive gzipped just like they should!

I've tried downloading the same file using wget and curl -O, in both cases the file also arrives un-gzipped!

As far as I can judge the only difference between my machines where I don't have this behaviour, and the one where I do, is that they are on different networks (i.e. at home vs. at work). I haven't had a chance to move the work system onto a different network yet, but I thought I'd ask this question even before doing that.

What on earth could explain this strange behaviour?

  1. On my work system this one, out of 4, pacman repo databases arrives un-gzipped.
  2. It arrives un-gzipped when using wget and curl -O manually.
  3. It does not arrive un-gzipped on ArchLinux systems on other networks.
share|improve this question
    
Check your aliases first; otherwise, strace your wget or curl call and see what's doing the gunzip. –  jjlin Apr 2 at 23:30
    
I've done all the downloading as root, and I have no aliases in root's config at all, so unfortunately that doesn't explain it. –  Magnus Apr 3 at 4:55
    
I've now done an strace of curl -O, and there seems to be nothing on the client machine doing the un-gzipping, i.e. the output of strace doesn't contain any mention of 'zip'. The same is true when using ltrace. I'm leaning towards the network doing something strange, would that be possible? –  Magnus Apr 3 at 7:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.