Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using /etc/inittab on RHEL 6.3 x86_64 system, we tried to respawn a binary: aka watchdog from newuser UID login when restarted, not as a root UID process. Made the following changes as inline. However, while testing the behaviour in initial and process restart time, every time the target binary: watchdog, is started as root user, not as newuser.

However, from shell login, we was able to bring up any process with another user name.

====

enter code here

cat /etc/inittab:

wd:345:respawn:/bin/su - newuser -c 'exec env LD_LIBRARY_PATH=/opt/binapp/common/watchdog /opt/binapp/common/watchdog/watchdog /opt/binapp/common/watchdog/watchdog.cfg >> /opt/binapp/common/watchdog/watchdog.stdout 2>&1'

id:3:initdefault:

enter code here

====

system info: Linux version 2.6.32-279.el6.x86_64 (mockbuild@x86-008.build.bos.redhat.com) (gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC) ) #1 SMP Wed Jun 13 18:24:36 EDT 2012

====

Tried with the following standard references without any success, any other hints would be highly appreciated.

http://serverfault.com/questions/318742/etc-inittab-respawn-script-migrating-from-rhel-centos-5-x-to-6-x

http://stackoverflow.com/questions/394984/best-practice-to-run-linux-service-as-a-different-user

====

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.