Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd like to get Firefox to work with OpenDNS, but still retain Firefox's standard behaviour when typing something on the location bar.

Before I set up things to run OpenDNS, if I typed google on the location bar, it'd redirect to Now, it redirects me to, showing me search results for the word google. It also retains this behaviour whenever I type a single word on the location bar.
The behaviour is slightly different when I type more than one word, but still not what I expected: it searches in Google for whatever I type. For instance, if I type google maps it gets me here.

Before I had set OpenDNS, if I typed a single word it'd either redirect me to the site at once, or if there was no clear match, it'd show me search results on Google.
Whenever I typed more than one word, it'd most likely redirect me to a site too (for google maps it'd get me directly to Google Maps' page), unless, once again, there was no clear match.

I've checked about:config, and everything (both keyword.enabled and keyword.URL) seems fine according to this page.

Is there any way I could get Firefox back to its old behaviour and also retain OpenDNS?

share|improve this question
Why are you using OpenDNS at all? I stopped using OpenDNS for this exact reason, they're giving back bogus answers in various situations. I started using Google's public DNS servers, the famous and and never looked back. – nitro2k01 Apr 18 '14 at 6:00

OpenDNS is doing something called a wildcard search return, and is therefore pre-empting Firefox from doing what you expect it to.

You maybe able to turn this off:

share|improve this answer
Thanks, but this does not seem to make the trick. – JNat Apr 5 '14 at 11:13
Perhaps you cannot change this behaviour from OpenDNS with their free service. – David Apr 5 '14 at 13:30
I was able to do what the link you provided said. It just didn't change any behaviour. – JNat Apr 5 '14 at 15:36
It may take time for setting to propagate out to their DNS servers. Or their free service may not honour that setting in some way. If you are using Windows, you could try ipconfig /flushdns. Just as an experiment, try using Googles DNS servers, and which I would expect work as you would like. Quite simply, you may not be able to disable the wildcard return feature of OpenDNS. – David Apr 5 '14 at 15:42

Fortunately there are Firefox add-ons which can get rid of the '' redirect (including for single word searches) - without needing to create an OpenDNS account or specify your IP to them on their website.

Try one of the following extensions:

  1. InstantFox (no restart) - to configure it as desired enable the "Standard search without shortcuts" feature up the top of the main settings panel and set your desired search engine in its 'edit' window also.

  2. Omnibar - requires restart but works right out of the box for basic single keyword searching going straight to the search engine that you set within Firefox itself. Also has options to tame it down and tweak things as desired.

It's true these address bar add-ons may bring a little extra baggage than 'simply removing this redirect' over the default firefox address bar itself and may also change the behaviour of some aspects of it - but in the end you may actually prefer its subtle changes (e.g. I noticed Omnibar seems to remove the 'Switch to Tab' feature, but I actually like that, I've been finding Switch to Tab very annoying!).

But in either case - it does take control of Firefox's address bar enough to override OpenDNS' annoying hijacking browser-side, where setting "keyword.url" in about:config isn't cutting it for all scenarios.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.