Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

No matter what I do, it will not install. I tried changing the SP thing and it had absolutely no effect. SP1 is installed. Visual Studio 2010 is installed. I'm running a 64 bit machine with Windows 7. I've tried running both the SP1 version of the SDK as well as the non-SP1 version. I installed Visual Studio 2010 Express from here and VS 2010 Express SP1 from here. I installed everything in the express package and it appears to have installed in /Program Files (x86)/ which is weird. The exact error the installer is showing is "You must have Microsoft Visual Studio 2010 SP1 installed on your computer before proceeding". Well, I'm looking at it right now. It's installed.

In Regedit:

HKLM > SOFTWARE > MICROSOFT > DEVDIV = There is no "vs" folder.

HKLM > SOFTWARE > WOW6432Node > MICROSOFT > DEVDIV > vs > 10.0 = SP change had no effect

I'm completely lost, I really need to get this SDK installed. Help.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.