Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Notepad++ 6.5.5 in my HP G62 which runs on Windows 7 Home Premium 64 bit. When I opened it for the first time its font was Courier New with font size 10. I don't liked that font and the theme. So I changed theme, font, font size and made the font bold. Then I pressed 'save and close button'. Then everything was changed as I specified.

When I opened notepad++ next time its font properties was changed to default, but theme was not changed to default. I specified my font needs again and saved it. But when ever I open notepad++ the font properties changes to default.

How can I avoid this problem and fix my font specifications forever ?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It sounds like the Notepad++ does not have permissions to write the configuration file. Try running it as an administrator: Either right click and select run as administrator, or hold down Ctrl+Shift while launching the application. While it running as an administrator, make the changes and save and close the application.

This should not occur in general, you should have sufficient permissions to read/write to your home directory where the configuration files are written (usually under C:\Users\%user_name%\ ). I would recommend uninstalling the Notepad++, and then reinstalling it. I believe in the installation there is option to change the location of the user settings, make sure it is in a location that your user has permissions to access.

In case steps do not fix the problem, your user might be corrupt, in which case you could make a new user and see if this fixes the problem, though this should be a last resort.

share|improve this answer
    
When I ran it with administrator permissions and made changes, it existed. –  TomJ Apr 5 at 16:42

You need to go to Settings > Style Configurator:

enter image description here

And change whatever you want to change there. Be sure to pick the "Default Style".

share|improve this answer
    
Its not working at all. –  TomJ Apr 5 at 16:08
    
@Tom More details please? Are you using any specific language? Because that works fine for me. Change the font, save, close, reopen and the font is the one I saved previously. –  Jerry Apr 5 at 16:10
    
I did this as you showed. But when opened notepad++ again font properties are not as I specified last time. –  TomJ Apr 5 at 16:14
    
@Tom Well, I cannot reproduce it. One last try: try going 'global override' and check the 'enable global font' checkbox, then pick the font you like: picture. –  Jerry Apr 5 at 16:18
    
I already tested that with no success. –  TomJ Apr 5 at 16:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.