Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every once in a while the right click menu is leaving around one of its items:

alt text

This bar sits on top of everything and the only way I can find to make them go away is to change something in the screen setting (e.i. move the alignment of my monitors a few pixels) to force a full redraw. This just started a week or so ago and I've made no hardware updates and /I/ didn't do anything with driver settings or the like.

Any ideas what might have changed or how to make it go away?

share|improve this question
1  
Could you give this a better title? –  MJeffryes Jul 17 '09 at 19:55

6 Answers 6

up vote 2 down vote accepted

If Microsoft don't know about this, then they haven't used Windows. This happens every so often with me - and a lot of other users.

It imagine that it is either:

  • A fundamental bug in their windowing/graphics systems,
  • too small to worry about, or
  • it is caused by some third party program or driver

I personally think it is either option one or two, but the point is Microsoft haven't fixed it. You could try updating your graphics drivers or seeing if any patches have been issued on Windows Update, but I don't think it'll have much impact.

I'm not sure about the state of play on Vista or 7, as there was a major renovation of the windowing system, and Aero works differently.

Also, for me (XP Pro and part of a domain), bringing up the "Windows Security" dialog (Ctrl+Alt+Del) usually clears any floating things.

share|improve this answer
    
On this system it's about once every 10 minutes. –  BCS Jul 17 '09 at 19:03
    
that's pretty often, I get it, but perhaps 4 times a week –  Nathan Koop Jul 17 '09 at 20:00

I believe it has something to do with GDI+ and how XP draws things directly to the screen. You might have noticed this when you can drag a window around and it leaves copies all over the place. In Vista and Windows 7, the Desktop Windows Manager handles those draw requests and is much less prone to that sort of behavior.

share|improve this answer

I've noticed this before once or twice on older NVIDIA graphics cards and in Virtual Machines. I do believe this to be a graphics card problem and it is extremely hard to replicate.

share|improve this answer
    
IIRC I'm running a ATI card and it's not at all hard to reproduce right now :b –  BCS Jul 17 '09 at 19:04
    
Funny enough I've never had the problem with an ATI card. I dropped NVIDIA a while back, with exception to the Apple machines I work on. –  Diago Jul 17 '09 at 19:10

It is a common bug and I've had it happen to me back in Win2k as well. Must have snuck into the kernel somewhere back then.

share|improve this answer

All versions of Windows have had this or a similar problem for almost as long as I can remember. It happens in Vista too.

share|improve this answer

Try turning down your Hardware Acceleration in the Display Properties Settings/Advanced. If that makes a difference, it's probably due to driver bugs.

In their quest to have the best benchmark times, the drivers are very aggressive at removing drawing requests that they think are redundant. Sometimes they get it wrong.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.