Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Brother DCP-145C printer installed and it does not print black ink. I tried running diagnostics and test pages, the driver is installed properly. It doesn't matter if I send the data from the pc, or use the scanning function. What could be the problem? Printer is brand new by the way, should i return it?

share|improve this question
1  
The black ink doesn't print if the heads need cleaning. Try running the cleaning function and see if it improves. You may have to run it multiple times. –  user42227 Jul 8 '10 at 2:57

3 Answers 3

Brother DCP-145C printer doesn't print in black if the color cartridges are out-of-ink.

Check if:

  1. the color cartridges are installed properly
  2. you can print in color without problems
share|improve this answer

If the printer stood in some storage facility for a long time the ink can dry and/or the heads can be clotted. Try using the cleaning function. If this doesn´t work you can also wet a paper tissue and put the ink cartridge on it to see if there is some ink coming out of it. But be sure that the tissue is just minimal wet and not dripping of water ;-)

When this doen´t bring up some color, it might be the head. I don´t know how the Brother DCP-145C is built so I can´t tell you if you can replace the head by yourself. So, you maybe should use the varanty. You also could try the e-mail function on the support site of brother. They might give you the proper solution because they (like exwyz said) confirmed the problem. I already used this function to get support for some fax-devices. It worked fine an I got my problem solved with theyr help ;-)

share|improve this answer

I have sent back to Brother Service Center twice already. Brother has confirmed that the print head is the problem. Met someone having same problem on DCP 165.

share|improve this answer
1  
It took you nearly a year to post this as a reply and you also created a new account when doing so? –  HaydnWVN Dec 10 '12 at 15:20

protected by studiohack May 3 '11 at 9:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?