Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to write multi-lines in one MS Excel cell.

But whenever I press the Enter key, the cell editing ends and the cursor moves to next cell. How can I avoid this?

share|improve this question
up vote 49 down vote accepted

What you want to do is to wrap the text in the current cell. You can do this manually by pressing Alt + Enter every time you want a new line

Or, you can set this as the default behaviour by pressing the Wrap Text in the Home tab on the Ribbon. Now, whenever you hit enter, it will automatically wrap the text onto a new line rather than a new cell.

enter image description here

share|improve this answer
The link here has rotted. Not sure what it was supposed to be. – Matt May 4 '15 at 20:36

You have to use Alt+Enter to enter a carriage return inside a cell.

share|improve this answer
  1. Edit a cell and type what you want on the first "row"
  2. Press one of the following, depending on your OS:

    Windows: Alt + Enter

    Mac: Ctrl + Option + Enter

  3. Type what you want on the next "row" in the same cell
  4. Repeat as needed.

Note that inserting carriage returns with the key combinations above produces different behavior than turning on Wrap Text. In the screenshot below, column A has the carriage returns and column B has Wrap Text turned on. Changing the width of a column with carriage returns doesn't remove them. Changing the width of a column with Wrap Text turned on will change where the lines break.

In-cell line breaks in Excel

share|improve this answer

Use the combination alt+enter

share|improve this answer

Alt + Enter never worked for me. I had to go to Format Cells and make sure that the Number tab was set to Text. That allowed me to see exactly as I had input. My issue could have been Mac specific though.

share|improve this answer

protected by Community Nov 12 '13 at 9:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.