Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using KDE4 with 4 workspaces (or virtual desktops), and I would like only the windows of only the current workspace to show up on the taskbar. How can I do that?

Edit: OpenSUSE 11.2 here. There's no "task manager settings" in the right click menu.

Thanks

share|improve this question

Right click on Panel, Task Manager settings (in my config Alt + D, S) - and there you go:

  • Show tasks from current desktop

in Filters section. Using latest Kubuntu Karmic here.

share|improve this answer
    
Thank you, your answer gave me the hint I needed. – Tamás Szelei Nov 22 '09 at 14:34

I had to right-click in a part of the task manager area that wasn't showing a task. Once the task manager area is full, there seems to be noplace where the task manager settings can be invoked. Seems like a bug to me.

share|improve this answer
up vote 0 down vote accepted

I managed to do it according to a comment by user moduc from digg:

To go to the task manager settings is not straight forward, or would I say stupid design at best. First, I have to right click on the task manager, then Click on Panel Settings. Next, I right click on one of the icons of an app or window, and click on Task manager settings.

This exactly worked.

share|improve this answer
    
In my kde 4.3 I just right click on the panel, select task manager settings and that's it. – Marcin Gil Nov 23 '09 at 4:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .