Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a Windows developer and I want to get started with Windows Phone 8. I previously had Oracle VirtualBox installed but was told that the Windows Phone Emulator needs Hyper-V, which doesn't work well with VirtualBox.

This wasn't an issue, so I uninstalled VirtualBox and added the Hyper-V feature (I'm using Windows 8.1).

I now cannot start the Hyper-V management service, I get the error below when I try and start through services.msc:

enter image description here

Couple of additional bits of information...

I uninstalled Hyper-V when I first got the laptop, as I wanted to use VirtualBox. VirtualBox was running fine so I don't think there is anything wrong with my laptop hardware.

I also went into my BIOS, disabled Virtualization and then removed the battery for a couple of minutes (on the advise of a tech guy) and then re-enabled it and re-booted but I still get the same error.

Laptop is a Toshiba Satellite L850, link below:

Toshiba Laptop

Can anyone suggest anything to try? At the minute, all I can think is to perform a clean re-install of Windows.

share|improve this question

migrated from serverfault.com Apr 7 '14 at 12:03

This question came from our site for system and network administrators.

    
Yep, added back in that I renabled it again. –  Paul Apr 7 '14 at 8:13
    
And what does the event log say? –  TomTom Apr 7 '14 at 8:15
    
The same as the screenshot that I added: The Hyper-V Virtual Machine Management service terminated with the following error: Invalid pointer –  Paul Apr 7 '14 at 8:16
    
Any suggestions? –  Paul Apr 7 '14 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.