Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to route the TeamViewer desktop client through an SSH tunnel I've made using a home server (with DD-WRT) and PuTTY on my end. In PuTTY, I chose port 1080 to Dynamic range, so it works fine and dandy as a socks proxy in my web browser.

However I know SSH is for more nice stuff. I managed to use socat thanks to someone else who helped me here on this group for routing GMail's IMAP server to my Outlook client, but alas, IMAP and SMTP/POP3 servers are well-known. Teamviewer's servers are a lot and I bet they use dynamic port ranges locally, making the issue harder to tackle.

TeamViewer has an option to set a proxy, but it doesn't use the socks proxy. I assume it must use an HTTP proxy, but in my end I'm behind a very restrictive proxy server (with authentication) which doesn't let me connect to TeamViewer's servers, and it's also the reason why I had to use socat (since it allowed to provide credentials).

Anyways, anyone have any idea on what can I use, either socat or another solution (I have cygwin, if it helps) to help me use the TeamViewer client? I tried logging on the web system but when I try to connect it launches the desktop client, so it's a no-go :(

Any ideas are welcome. Thanks in advance :)!

share|improve this question

Yes. Goto Extras->Options->General ...click on "Configure" for proxy settings. Change to manual proxy and for Proxy IP enter socks5://127.0.0.1 and the port you are using. Obviously change the 127.0.0.1 to whatever IP you are wanting to use.

share|improve this answer
    
Fantastic! The socks5:// protocol prefix was the missing piece. – TimH Jun 30 at 14:56
up vote 2 down vote accepted

Alright, for those interested, I managed to do it, albeit with a trial app, it's something at least:

  1. Download proxifier portable, go to Profile -> Advanced -> Proxification Engine -> Change Hook Type to Module Copy.
  2. STOP TeamViewer Service (Start -> Run -> services.msc)
  3. Start TeamViewer THROUGH the Start Menu shortcut. Proxifier will hook into TeamViewer's startup client AND in consequence to the service because it is started by TeamViewer and not the service console, allowing it to be hooked correctly.

Enjoy! :D

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .