Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have been trying to set this up for days and cannot get it to work properly. I am trying to replace our home router (a crappy Thomson router provided by our ISP) with a PFSense box repurposed from a laptop with a dead screen. Here is what I have:

  • PFSense box running 2.1.1-RELEASE(amd64)
    • 2 NICs: an ethernet and wireless card
  • A cheap 8-port unmanaged switch
  • 3 different routers, each with a separate internet connection (each cheap and none very fast on its own)

What I am ideally trying to achieve is a single wireless network in the house, to which all of the family's devices could connect. This unified network would then load balance all of the requests, keeping everything fast for everyone. I found a post detailing how to do basically what I want here but I can't get the VLANing to work.

I am currently testing with 2 of the three WANs. On my LAN, the PFSense box is the DHCP server for a 192.168.0.1/24 network. This is also my WLAN running from the wireless NIC on the PFSense box. The ethernet NIC and each of the WAN routers is plugged into the unmanaged switch. One WAN is on a 192.168.1.1/24 network where the PFSense box has a static IP of 192.168.1.1 and the WAN router has an IP of 192.168.1.2. This is assigned to the re0 (ethernet) interface of the PFSense box. The other WAN is on a 192.168.2.1/24 network where the PFSense box has a static IP of 192.168.2.1 and the WAN router has an IP of 192.168.2.3. This is assigned to a VLAN interface on the re0 NIC.

Both the 192.168.1.2 and 192.168.2.3 routers have been set as gateways for their respective networks and interfaces. However, while the 192.168.1.2 route works fine, I cannot even ping 192.168.2.3. I can ping the PFSense box on all of its addresses though.

I'm sure there is something simple that I am missing, but I can't figure it out. Any ideas?

share|improve this question

1 Answer 1

Try setting up a static route on the problem router? Wan (as another subnet) cant ping any hosts on the other subby unless you nat it. But to get around nat you can setup a static route.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.