Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Windows Server 2012 R2 Essentials I have two identical network cards. Both cards are connected to the same switch and the two switch ports are configured to the same VLAN. The network interfaces have different IP addresses on the same subnet:

Interface 1: 192.168.1.11/24
Interface 2: 192.168.1.21/24

route print (shortened to the relevant lines) tells the following:

  192.168.1.0    255.255.255.0   On-link      192.168.1.21    276
  192.168.1.0    255.255.255.0   On-link      192.168.1.11    276
 192.168.1.11  255.255.255.255   On-link      192.168.1.11    276
 192.168.1.21  255.255.255.255   On-link      192.168.1.21    276
192.168.1.255  255.255.255.255   On-link      192.168.1.21    276
192.168.1.255  255.255.255.255   On-link      192.168.1.11    276

I need to make sure, that connections initiated by this machine to other nodes on the 192.168.1.0 subnet (outgoing connections) use the second interface (the one with the IP 192.168.1.21). Incoming connections shall be possible on both interfaces.

What I already tried:

  • I changed the order of the interfaces in the Adapter Settings/Advanced/Advanced Settings Dialog Changed Priorities - Interface 1 was first before

  • I tried to manually change the interface metric under the Interface Settings/TCPIPv4/Advanced

Both ways did not make outgoing connections to use the second interface.

What can I do to give Interface 2 a higher priority for outgoing connections?

share|improve this question

1 Answer 1

After some extra trial-and-error, using the Adapter Settings/Advanced/Advanced Settings dialog was the right approach, and led to the result I needed. All that was missing was a reboot after changing the settings.

For all those with the same problem:

  • Open the "Network and Sharing Center" and open the Adapter properties.
  • Press the "Alt" key to get the menu strip, click on "Advanced" and "Advanced Settings"

You'll see this dialog:

Settings Dialog

Use the arrows next to the first list to sort your adapters. The first adapter in the list has the highest priority. These settings do not change the way incoming connections are handled.

There's no need to touch the metric settings of the interfaces. They work in automatic mode perfectly.

You might need to reboot to get the settings applied.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.