Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have built the following VM in Windows Azure for a small web server for my client. Client OS: Windows 8 Server OS: Using OpenLogic's Linux CentOS 6.5 from Azure list

In the Server, the following packages are installed:

yum groupinstall "X Window System" "Desktop" (based on CentOS wiki but not sure what is the difference between "Desktop" and "Basic-Desktop" in some tutorials

Edit: Basic-Desktop is not fully installed while Desktop is fully installed for all features. "Desktop" is known as "Gnome Desktop Environment" in previous version.

yum vino-server

Edit: vino-server is VNC server for Gnome, tigervnc-server is required for CentOS 6.5 as a full featured VNC server

Now using Putty SSH for Windows to connect the Linux server without problem.

Based on the search in Internet, vino-server is a remote desktop based for VNC(Virtual Network Computing) and RDP(Remote Desktop Protocol). For using Windows RDP, XRDP is required while VNC could be used without any further packages but a bit of configurations.

Considerations about XRDP for CentOS

Since there is no native build XRDP for CentOS so I have to build myself. I didn't try it yet because according to a system engineer, building from source is not good idea and not secure for a production server. So to avoid it, I try to connect by VNC.

VNC Setting up difficulties

However, although I added ucd/tcp port 5900 to iptables and endpoints in Azure management portal, I cannot config the "Activating Remote Desktop Access" because I am in Putty terminal, no GUI can be opened. I found a command vino-preferences to setup which cannot be opened in Putty. So, I tried XMing to open up the terminal.

-A INPUT -m state --state NEW -m tcp -p tcp --dport 5900 -j ACCEPT

-A INPUT -m state --state NEW -m udp -p udp --dport 5900 -j ACCEPT

Xming for Windows setting up difficulties

I installed Xming, and fonts for it. I setup the Putty according to @NobleUplift's question: How do I get X11 Forwarding to work on Windows with PuTTY and Xming? and based on some other researches. Suppose Xming is using SSH Tunneling with Putty, that Putty will forward needed information to X Window.

X11Forwarding yes

X11DisplayOffset 10

X11UseLocalhost yes

AddressFamily inet

After these configurations and double click XMing shortcut configured for the above account, it does not open anything nor staying in Windows taskbar after input "password". It close immediately.

So I am now stuck here because I cannot config the VNC and I cannot connect with Xming neither. I hope the above description is adequate and any help is appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

With the settings in the question is right without problem.

The Solution to Xming for Windows in the case is like this:

The running order of Xming and Putty

After installation of Xming for Windows, just run Xlaunch to config and then run xming. Config option: for

  • multi windows
  • start no client
  • and then next and complete

Once it(Xming) is opened, It will stay in Windows taskbar. Then run Putty for the SSH account well configured for X11 Forward, this time, when xclock is run in the command, it will then forward to XWindows and open in your Windows desktop.

** the current Login identity for current session is also important **

If using SSH to connect Azure, the default user is not root. To elevate the privilege, using command sudo su is necessary. If running Xming with Putty and X11 Forwarding turned on. The forwarding is working for the first login. If issued the sudo su command. The link will be broken and GTK application such as xclock is no more working for the elevated account.

So make sure this is the first login user and to test the desktop installation, run xclock in the command line, if in Putty, error message will be displayed for it cannot be opened.

For CentOS 6.5, tigervnc-server is needed

However, when the VNC is connected, it is blank with nothing. Because the Vino Server is VNC server for Gnome. To properly install VNC server, tigervnc-server is necessary. For details please refer to CentOS HowTos -> VNC-Server

Tips:

The previous failure is mainly due to using Xlaunch to create a config to run for Putty which is a tutorial found in the web which is not working. The above running order make it working in my own case. I cannot say the not working method is wrong, maybe it is for other purpose that I didn't know yet.

After that, because Xming is working for xclock, so it is also working for vino-preference now. The VNC is then immediately working to connect the remote Linux on azure after check the Allow other users to view your desktop option and uncheck You must confirm each access.... But because in non-root-elevated, vino-preference is not being saved, it is not a proper way to setup the VNC, please refer to above link for details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.