Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In windows 8.1 and below, the mouse would seamlessly move through all my monitors.

However, in windows 8.1 update 1 the mouse needs to be going at a certain speed before it goes to a different monitor. How do I disable this?

A google search has turned up nothing, so I'm not sure what exactly is going on

share|improve this question
    
Downvote for no evident research effort. – TorpedoBench Apr 8 '14 at 23:42
1  
@TorpedoBench what do you want me to say. I have researched it but nothing showed up. Windows 8.1 was released hours ago so there won't be anything that shows up soon. As long as it hasn't been asked on SU before it's encouraged to ask - google has to index something and it might as well be SO. – Frankie Apr 8 '14 at 23:44
3  
@TorpedoBench Either way, it's encouraged to ask questions if it's not on SO it's encouraged to be ask. Furthermore, there's nothing that comes up so I can't link to anything. My brother is also experiencing it so I assume it's not specific to me. – Frankie Apr 8 '14 at 23:49
2  
@TorpedoBench I added to that the post. Either way, it's encouraged to ask questions on SO even if it's answered elsewhere. – Frankie Apr 8 '14 at 23:52
1  
@TorpedoBench I don't think you're reading my posts. Even if it is answered elsewhere, it is fine to ask with no mention whatsoever. The logic behind this is that google has to index something, and it might as well be SO. Mine hasn't been answered at all. – Frankie Apr 8 '14 at 23:57
up vote 3 down vote accepted

@Jason Stevenson's solution worked best for me, however I found a case when it does not work as expected.

This MouseMonitorEscapeSpeed value does not seem to be a True/False toggle with 0/1, but more an integer value. A value of 1 does not fix this issue in all scenarios moving from monitor to monitor.

To reproduce the issue when using 1 for MouseMonitorEscapeSpeed

  1. Set both MouseMonitorEscapeSpeed registry entries to 1
  2. Reboot the machine or restart the Explorer.exe process
  3. Turn off taskbars on multiple displays (as shown by @vanquishuk)
  4. Unlock the main taskbar and move it to the right side of the left monitor
  5. Move the mouse very slowly from the left monitor to the right one (you should see the mouse get stuck for a little bit in between)
  6. Moving from the right monitor to the left and the mouse does not stick

With the below registry entries I have found the solution works in all scenarios I can think of (including having the taskbar on the side of your monitor).

--- Registry File ---

Windows Registry Editor Version 5.00

;
; Fix mouse stickiness between monitors and mouse getting stuck in corners between monitors
;

[HKEY_CURRENT_USER\Control Panel\Desktop]
"MouseCornerClipLength"="0"
"MouseMonitorEscapeSpeed"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell\EdgeUi]
"MouseMonitorEscapeSpeed"=dword:00000000
share|improve this answer
    
Thanks for providing the .reg file :) Saves time navigating regedit. – Ross Allan Aug 4 '15 at 11:37
1  
Didn't work for me on Windows 10 – brett rogers Aug 27 '15 at 6:13
    
There is a bug open for the MouseCornerClipLength setting which I also found does not work in windows 10. Microsoft has acknowledged it. I have not attempted the MouseMonitorEscapeSpeed setting as it is not bothering me in windows 10. It seems to be disabled by default when you are not dragging a window. I will check if I can figure out how to turn it off though. – Joseph Sep 1 '15 at 2:05
    
What values should I use if I want to enable this feature?? My windows 10 box lets the mouse go from one screen to the other without "catching" it for a while, which is a desired feature for me. I use one screen in top of the other, if that matters. This feature was in Windows 8.1 before I upgraded to Windows 10 a couple of days ago. I tried changing the three values to "1","10" and "100" to see if there's any difference, bot none had any effect. I am restarting explorer.exe between the tests. – ricardomenzer Dec 3 '15 at 12:25
    
I think this setting no longer works in windows 10, try looking in settings under System>Multitasking. – Joseph Dec 24 '15 at 1:18

The selected answer no longer solves the issue on the most recent Windows 8.1 updates, or in Windows 10.

To properly solve this issue in later Windows versions you must edit this key here, changing the value from 0 to 1:

HKEY_CURRENT_USER\Control Panel\Desktop\MouseMonitorEscapeSpeed

And you must also add a missing key to the following location:

HKCU\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell\EdgeUI

Create a DWORD value MouseMonitorEscapeSpeed set to 1

Finally you must kill the Explorer.exe process from task manager, and then re-launch it; alternatively you could restart your PC for the change to take affect.

share|improve this answer
    
This works for me, thanks Jason! – Stony Jul 24 '15 at 10:38
1  
Not working for me in Windows 10 – brett rogers Aug 27 '15 at 1:32
1  
Still works for me on the release build... Did you remember to kill explorer or restart your PC? – Jason Stevenson Aug 28 '15 at 15:53

While some reported that this problem disappeared after changing seemingly unrelated windows settings (such as the "Show taskbar on all displays"), none of this worked for me.

However, after changing the registry value

    HKEY_CURRENT_USER\Control Panel\Desktop\MouseMonitorEscapeSpeed

from it's default value (0 on Win 8.1 Pro build 9600) to 1 and rebooting the "sticky edges bug/feature" seems to be gone.

There is also MouseCornerClipLength in the same location which might be of interest if you want to disable the sticky corners too (set it to 0 in that case).

EDIT After changing MouseMonitorEscapeSpeed back to 0 the problem appeared again after hibernation. Value 1 seems to disable sticky monitor edges without any side effects.

share|improve this answer
    
Re: Setting MouseMonitorEscapeSpeed to 1 - I've noticed that upon immediate boot up, the sticky edges may still be there. If you wait 1-2 minutes, it then stops. – Spongeboy Aug 12 '14 at 23:19
    
@TorpedoBench No longer works with new Windows 8.1 updates and Windows 10. See my solution below. – Jason Stevenson Nov 15 '14 at 0:49

Found a way to fix it for my self. Un-check this box: Right click task bar > Properties > Task bar Tab Once un-checked hit apply, then you can re-check it and hit apply again and the mouse should no longer get stuck.

enter image description here

share|improve this answer
    
I need the taskbar on all my displays though – Frankie Apr 11 '14 at 17:38
    
@Chipperyman - turning it off and on seems to disable it for that session. Though this is likely a bug, and may be fixed by MS at some stage. – Spongeboy Aug 12 '14 at 23:17
    
This worked perfectly for me. Thank you @vanquishuk! – Lone Coder Jan 12 '15 at 22:53

I've found a solution that does not need an explorer.exe restart or system reboot.

Steps:

  1. go to start screen
  2. click a metro app (onenote in my test case)
  3. move mouse to top left corner and click so it switches app (to desktop or to another metro app; doesn't matter)

Now mouse will be sticky thru out ALL edges of the monitors.

It comes from user Riasat from MS forum: http://answers.microsoft.com/en-us/windows/forum/windows8_1-tms/mouse-stickiness-change-with-multiple-monitors/a4eb4cc9-def1-4e80-b823-83460339afb8

You can close the metro app after it or kill it through task manager.

Hope this will help you it's really annoying bug O.o

share|improve this answer

On Windows 10, go to:

Control Panel\All Control Panel Items\Ease of Access Center\Make the mouse easier to use

which I found by searching settings for 'edge'.

Check the box for Prevent windows from being automatically arranged when moved to the edge of the screen.

share|improve this answer
    
While that solves the in-between monitors issues for dragging windows between displays, it also deactivates the feature for dragging a window towards the top of a screen to maximize it. It turns off the feature completely. I want to keep the Win7 portion, but disable the Win8/10 parts. – Kdansky Jan 3 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.