Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am sitting behind a company proxy. To start vagrant i had to use

set HTTP_proxy=http://http-proxy.example.org:9999

i tryed using netsh winhttp but that didn't work. So now my command line uses the proxy, but now it also uses it for localhost / 127.0.0.1.

Is there a way to bypass the proxy?

I already tryed setting no_proxy like this

set no_proxy=localhost;127.0.0.*
share|improve this question
    
Is your proxy properly configured in Internet Explorer? –  Daniel B Apr 11 at 7:56
    
@DanielB Yes it is and i tried netsh winhttp import proxy source=ie as well. –  Andresch Serj Apr 11 at 7:57
    
I guess that would've been too easy. Still, I believe setting the WinHTTP proxy isn't going to help either. Instead, you might want to take a look at vagrant-proxyconf. –  Daniel B Apr 11 at 8:01
    
been there, done that: vagrant-proxyconf is configured and works, otherwise i wouldn't be able to get to the point where i can not connect to the VM in the first place :( –  Andresch Serj Apr 11 at 8:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.