Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have vmware player, and I am running a special OS therein.

My computer has two network interfaces, let's call them eth0 and eth1.

I want to configure my computer so that all network traffic goes eth0 if and only if it originates in my virtual machine. If traffic belongs to my host OS then I want it to go thru eth1.

share|improve this question

migrated from stackoverflow.com Nov 22 '09 at 20:25

This question came from our site for professional and enthusiast programmers.

    
I see now that your question is tagged with "windows-7". You should include this detail in the description, as it helps focus the answers. –  Jason R. Coombs Nov 22 '09 at 20:48

4 Answers 4

The simple answer is just configure eth0 without any IP address and then configure VMWare Player to bridge the virtual network interface to eth0 on the host. Configure eth1 on the host like you would normally.

If the guest and host should only communicate through their respective interfaces, you can just leave eth0 on the host configured without any IP address. In this way, if the host and guest ever need to communicate, they will need to go through whatever networking infrastructure is outside of the described system.

share|improve this answer

Which version of VMware Player are you running? If v2 or earlier, look for vmnetcfg in the install directory. You can use it to configure networking for your VMware clients. You can configure the default bridged network to use the host's eth0 instead of what ever it is doing now. Then it is just up to you to configure your host's networking to only use eth0 (Jason's answer covers that)

vmnetcfg isn't installed by default with VMware Player 3, but I have a little blog post on how to extract and use it from the Player install package.

share|improve this answer

I would do the following: On the host machine use VMNETCFG (in the VMWare player folder) to change the "bridged" setting from automatic to bind the the adapter you want (in this case eth0). On the host machine set the binding order of your adapters to use eth1 first. On the guest set the network to use bridged. Note this will not prevent the host from accessing eth0 - at the very least the host will use that to handled the bridged communication to the guest. Changing the binding order simply makes applications on the host (unless specically bound to a adapter) try eth1 first. This is a good short description of network setup with VM: http://www.petri.co.il/virtual%5Fcreate%5Fnetwork%5Ftestlab%5Fvmware.htm

share|improve this answer
    
VMNETCFG can be hard to find, see my answer below. –  Alex R Sep 12 '10 at 16:06

You use Windows Vista or Windows 7? I had this problem in both.

A bug in the installer prevents the installation of the tool vmnetcfg.exe

See user19608's answer, and then if you can't find vmnetcfg.exe, do this:

Run setup again like this from Command Prompt (CMD):

VMware-player-3.1.1-282343.exe /e .\vmplayer

In vmplayer subdir you will find network.cab - extract it in explorer or 7zip, then find vmnetcfg.exe and copy to c:\Program Files (x86)\VMware\VMware Player

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.