Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, no matter what document type I'm using Internet Explorer will open all my HTML files as a Default Internet Explorer 7 Document Type. If I upload these HTML files to a server they'll show up just fine. Is there some kind of setting in Internet Explorer or meta tag I need? Doc Types I've tried, which again work when uploaded to a server but not locally (IE Only)

<!DOCTYPE html>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

Here's what my dev tools tells me:

enter image description here

share|improve this question
    
Are you on a domain? Have you checked Compatibility settings for "intranet" zones? –  Ƭᴇcʜιᴇ007 Apr 10 '14 at 17:20
    
Under zones I'm just on Internet, not local or anything –  Howdy_McGee Apr 10 '14 at 17:31
    
Have you tried resetting IE to defaults? –  Moses Apr 10 '14 at 18:12

1 Answer 1

It sounds like you are displaying local files in Compatibility view. In IE, go to Tools/Compatibility View Settings. Check to ensure that your local server is not in the list of sites to display in Compatibility view. Also, ensure that the "display intranet sites in Compatibility View" checkbox is unchecked.

There is also a way to ensure IE does not display in Compatibility view by using the following vendor specific meta tag in the html head:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

You can read more about that here http://msdn.microsoft.com/en-us/library/ie/ms533876(v=vs.85).aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.