Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I write “Thus x is larger than y.” in normal mode in Word, no error is reported in spelling check. But if I turn “x” and “y” into equations (by selecting them and then giving the command Insert → Equation for example), in Word 2007 or newer, a spelling error is reported: space before punctuation. This is rather inconvenient, and the suggested “correction” would remove the space between “than” and “y”.

enter image description here

So Word seems to act as if “y” were not there at all. Is there any fix to this? Problems like this are frequent in mathematical texts when inline equations are used (and for typographic uniformity, math expressions should all be written as equations in text, if the equation tools are used at all).

I know that I can avoid the problem by putting a space inside the equation, so that instead of “...than [y].” (where brackets indicate a construct created with equation tools) I use “...than[ y].” It just sounds illogical and somewhat inconvenient (if an equation is copied, the space is copied in it, and in the general case, a space might be needed on either side or on both sides).

share|improve this question
    
Putting a no-width non-break character immediately before and after the equation seems to prevent this error from being flagged, but you would need to check more thoroughly. Not ideal, and when it comes before the equation, the character looks as if it's inside the equation "box" (although it isn't). But perhaps a workaround that still allows you to keep the spell/grammar check and avoid polluting every equation. –  bibadia Apr 12 at 8:40
    
@bibadia, doesn’t work for me—I suppose you meant U+FEFF, but it does not have such an effect when I test the idea with my sample sentence in Word 2013. –  Jukka K. Korpela Apr 12 at 12:20
    
I mean 0x200C - you can insert it from Insert->Symbol->More Symbols->Special Characters. 0xFEFF is the Byte Order Mark, I think, which is something else altogether. –  bibadia Apr 12 at 16:36
    
U+FEFF is ZERO WIDTH NO-BREAK SPACE, which is also used as BOM, but only at the start data. U+200C ZERO WIDTH NON-JOINER is defined (in the Unicode standard) to disabled ligature beahavior, but Word uses it differently, and in Insert → Symbol → More Symbols → Special character, “No-Width Optional Break” inserts it. It indeed seems to prevent the error messages, but I think it needs to be used carefully. E.g., in my example, using it before “y” has the desired effect, but if you also put it after “y”, it will act as optional line break, causing perhaps “.” to be pushed at the start of a line! –  Jukka K. Korpela Apr 12 at 17:20
    
@bibadia, can you formulate your comments as an answer? –  Jukka K. Korpela Apr 12 at 17:21

2 Answers 2

up vote 2 down vote accepted

Word lets you insert what it calls a "no-width non-break" character via Insert->Symbol->More Symbols->Special Character. This is Unicode U+200C, known in Unicode as ZERO-WIDTH NON-JOINER.

If you insert one of those immediately before the "y" equation it appears to prevent this particular error from being flagged.

Not ideal, and when it comes before the equation, the character looks as if it's inside the equation "box" (although it isn't).

The OP has commented that it needs to be used carefully, e.g. because used after the "y" it may act as an optional line break, pushing the "." onto the next line.

share|improve this answer
    
This seems to be the best answer we can have, with this inconvenient behavior of Word. We need to choose between this method, Timothy’s answer of suppressing punctuation checks, the use of spaces inside the formula as described in the question, and just ignoring the messages (hoping we won’t ignore too many real errors in the process). –  Jukka K. Korpela Apr 12 at 20:53

If you are comfortable with it, you can turn off the grammar check for punctuation. This will prevent this "error message" from appearing, but will also discard other suggestions about punctuation (such as improper use of semicolons, etc.)

In Word 2007/2010, this can be done in the Proofing Options:

Word Proofing Options

I am assuming the option is the same or very similar in Word 2013, which you are using. I am not aware of an option to disable this just for cases involving equations, and I don't think that it exists.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.