Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer Aspire 4740 with Windows 7 Home Premium installed in it. This laptop has a local disk C of 90 GB (where Windows 7 is installed) and disk D 270 GB in it. Last week I suddenly could not boot into Windows. I tried to recover it using cmd, but I failed.

There are important documents on it, and I need to access them. So I'm using a Ubuntu 12.04 LTS (Precise Pangolin) live USB (which I'm using "try only" version) to access the local disk C. However I can only mount disk D but cannot mount local disk C. When I double click on disk C, it says:

Cannot mount, because it is in pending operation

What can I do?

share|improve this question
    
Have you tried to mount it read only? (see eg here: askubuntu.com/questions/296331/…); if you need to find partition ids serverfault.com/questions/190685/… –  wmz Apr 12 '14 at 8:38

1 Answer 1

The issue that you are facing, is that the drive is still marked as active from windows, so the "in use" marker is set to yes, more or less.

I found a post about this from another forum, with the following workaround:

The only current solution I have at this time is Symantec Partition Magic

and that involves a work around. For this to work, I have to create a temporary Primary partition, then (2) mark said temporary Primary partition Active and then (3) delete said Primary partition - this will leave all prior drives uneffected and no drives Active on the hard drive

One side effect of this work around - Partition Magic will alter a Windows Multiboot "boot.ini" file after any partition is deleted

I know that this does not include the ubuntu live disk, but none-the-less, if it works, it works, right? Let me know if this helps you.

Referenced Post: Tom's Hardware

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.