Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having an issue with a block of machines running debian 6 (ARM). When I ssh to them I'm only able to get about 3 lines of output from any command (eg 'ps -ax') before the session is locked up and must be killed.

Running 'ssh -vvv' doesn't show any errors.

EDIT: I can get single commands to execute: ssh root@server "ps -ax". If I login and try the same command the lock-up occurs.

What else should I try to see what's going on?

share|improve this question
    
Do you know the specs of the servers? ie, are they low end VPSes with 128mb of RAM or so and you're trying to run a RAM intensive service? –  ekaj Apr 11 at 21:24
    
servers are fanless ARM based machines. Small footprint. 1g of RAM. Not much else running. –  ethrbunny Apr 11 at 21:38
    
Is it possible to pipe the output to a text file (yeah, you'll lose the session) but then look at the text file the next time you log it? –  ekaj Apr 12 at 2:22

2 Answers 2

This doesn't sound like an ssh error, it sounds like a networking error, specifically an issue with the MTU settings. Try setting up MTU clamping or ensuring the MTU on both the client and server is less then the maximum MTU across the path.

share|improve this answer
    
I wondered about MTU size so I tried this: ping -c 1 -s $((5000-28)) -M do machine-ip - came back and told me mtu=1500 which is what's set on the machine. –  ethrbunny Apr 11 at 23:08

Maybe ssh -v [target] at initial connection.

share|improve this answer
    
Tried this: got lots of info until the lock-up. Then silence. Waited 20-30 minutes with nothing further. –  ethrbunny Apr 11 at 23:11
    
Is there a log on the server end? –  Ben Lavender Apr 11 at 23:47
    
Can't really get to it. –  ethrbunny Apr 11 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.