Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed that there are many posts on Super User about ClearType, but none seems to address the question I have.

I am on Windows 7 and I find fonts very fuzzy. To be specific, some letters are more fuzzy than others, and it's not specific to the letters, it's more about positioning. If I move my Windows to a slightly different position, then different sets of letters are fuzzy.

I tried to do the ClearType tuning, but I can't find a selection that looks sharp. I tried to turn off ClearType altogether, but it gets worse. I turn off antialiasing in systemspropertiesperformance.exe and it doesn't help much.

My prior experience is with Windows XP. And fonts look fine there. I think I prefer having jagged edges over anti-aliasing. Trying to round the edges just makes my eye sore.

I'm using a 17 inch monitor, 1280x1024. My friends who are also on Windows 7 using laptops still have fuzzy fonts, but they are a lot better. I think it's because their resolution is much higher with respect to their screen sizes.

EDIT: Interestingly the problem might not be font settings after all. I screenshot the text, same thing also happens to the screenshot!! Even though some letter are still fuzzier than others. I should hook the monitor up to a computer with Windows XP to check again.

EDIT2: Same monitor on Windows XP looks fine. Comparing text screenshots made in Windows XP and Windows 7 on Windows XP I do find Windows 7 fonts fuzzier than one on Windows XP. However, even when viewing screenshot from Windows XP on Windows 7, it looks very fuzzy! And this is specific to Windows 7 since I'm using the same monitor.

EDIT3: Problem solved. Posted under Bobince's reply. Thank you all. :)

share|improve this question
    
What is your monitor's model number? –  William Hilsum Nov 23 '09 at 4:00
    
i don't quite see a question here... –  RCIX Nov 23 '09 at 4:45
    
Hi, the question is how to fix the fuzziness. Or how to bring back the way XP handles fonts. –  huggie Nov 23 '09 at 8:53
    
Wil: some no-label monitor manufactured by chimei I pick up at a small store. I am pretty sure the monitor isn't the issue. Because the effect only appear in win7. And one friend who used to run Vista also used to observe the same effect on his monitor. But he got used to it. –  huggie Nov 23 '09 at 8:56

4 Answers 4

If I move my windows to a slightly different position, then different set of letters are fuzzy.

What type of monitor are you using and how is it connected?

My suspicion is you're talking about a flat-panel display connected with an analogue interface such as a VGA cable. The screen is failing to sync exactly with the timing of the signal and consequently there isn't a 1:1 match between the pixels the computer is sending and the physical ones on the screen. This will make everything slightly blurry and though text will be one of the first things you notice, changing the font settings won't help.

You should be able to improve matters by adjusting the clock rate and offset from the monitor's settings menu. There is usually also an ‘auto’ button that will try to guess it again. Use a sharp pixel image so you can immediately see any blurring due to desync.

A digital display being driven by analogue is an unhappy thing and though you can optimise it as above will never look nearly as sharp as one connected via digital links (DVI, HDMI or DisplayPort). If you have a digital input on the screen, you really should be using that. (It is unfortunate and pointless that many cheap-and-nasty displays are sold with only VGA input.)

share|improve this answer
    
Agreed, sounds like its connected via RGB rather than DVI or HDMI. Refresh rate may also potentially be an issue. –  Michael Galos Nov 23 '09 at 10:20
    
I think I may have found out why. When I use Windows 7 at native resolution (1280 x 1024), auto-adjust leaves one black strip of margin on the right. Nothing is left out of the screen, the horizontal width just "shrunk". OSD only allows me to adjust the horizontal position, but not the "span". Ouch. –  huggie Nov 25 '09 at 4:04
1  
Problem solved!! (Even though I don't exactly know what I did.) I tweaked refresh rate from 60 to 75 and then change resolution from and back to native resolution. The setting I have right now is exactly how I started, 60 mhz and 1280x1024, but auto-adjust works correctly now. (It reverts back to 60 mhz by itself) –  huggie Nov 25 '09 at 4:15
    
My LCD monitor makes a weird noise when visiting the checkerboard site. –  kinokijuf Jan 28 '12 at 20:00
    
@huggie I'm in the same boat at work and have not easy way to obtain a digital cable. What I found out is that running the screen's auto calibrate function AGAIN after setting the properties in windows did the trick. My guess is that the screen's calibration was running at the same time as windows's calibration and hence calibrated on a temporary state. –  Boris Callens Nov 28 '12 at 15:10

Okay, heres a few suggestions.

I'll say the obvious ones now (This is not making any assumptions on your intelligence, some things just get overlooked by mistake at times)

  • Ensure that your monitor has been Auto Adjusted to your resolution. Every thing i'm hearing here seems to point to your monitor not being adjusted properly.

  • Turn off ClearType, Right click on "Computer", click Properties > Advanced System Settings > And enable "Smooth Edges on screen fonts" (I don't know if thats "ClearType" but i was under the impression that ClearType was an additional anti-aliasing feature on top of that one for laptops.

  • Perhaps change your resolution and see if it looks better on some other resolutions, if it does, then refer to point one.

Hope that helped some!

share|improve this answer
    
1. Auto-adjust doesn't fix it. 2. I did that, it was worst so I have to turn it back on. 3. It's at native resolution. :( –  huggie Nov 23 '09 at 8:51
    
Oops. On 2 I was referring to cleartype setting. But yeah I tried that, it still looks bad. That's the same thing as systemspropertiesperformance.exe. –  huggie Nov 23 '09 at 8:53
    
Okay, in keeping to everyone elses comments, try to put the refresh rate down to the lowest available for your screens native resolution. Also, could you put the screen shot online so everyone could see it, I'm sure it would help us? –  SevenT2 Nov 23 '09 at 13:09
    
Yeah I was going to take a digital camera to physically take the screenshot but all a sudden I think I may have found out why. I replied under Bobince's reply. :) But I don't know how to fix it yet. –  huggie Nov 25 '09 at 4:07

Well, as others have noted, the native display resolution might be something to check first. Then you can run the ClearType Text Tuner. Just open the Start menu and type ClearType; "Adjust ClearType Text" should appear in the list.

This applet will alow you to fine-tune ClearType and one of the very first choices is on RGB or BGR subpixel order. It may be that your monitor has BGR order and that definitely creates fuzziness.

share|improve this answer
    
I did that. It doesn't help. I hope it means turning off subpixel rendering. Turning off cleartype actually makes it worse. But anyhow it just isn't as crystal sharp as it was in Windows XP. –  huggie Nov 23 '09 at 8:58
    
I was also going to suggest the ClearType Text Tuner. You mean to say none of the 18 different rendering options helped? –  SevenT2 Nov 23 '09 at 16:37

This is how I did it:

  1. Right Clicked on desktop and chose "Personalise"

  2. Choose "Ease of Access Center"

  3. Choose "Make the Computer Easier to see"

  4. Everything Unticked except for "Turn Off all uneccesary animations (where possible)"

  5. And chose OK.

Made it better for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.