Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have one machine connect to network using two method :

Wireless - got internet access - Class C ip : 192.168.2.xx - Connect with local network with few PCs.


  • do not have internet access
  • Class A ip : 10.236.xx.xx
  • Connect with local network with 2 PCs only

I want to ping ip 10.236.xx.xx but don't want go through Wireless network. Only use LAN. but i can't turn off wireless network because i need to remote that machine from other site using teamviewer.

Right now, if I tracert the ip 10.236.xx.xx.. the first hops will go through (gateaway wireless) it should go for 10.236.xx.1 (gateaway LAN)

any advise?

share|improve this question
What OS are you using? Unix machines can do a ping -I eth0 (or similar ethernet interface name) to select which interface it goes through. – Alan Shutko Apr 14 '14 at 2:42
@AlanShutko im using windows.. what the command for cmd? – user315384 Apr 14 '14 at 2:47
Have you tried setting the dhcp server on 10.236.x.x as your default gateway? – spuder Apr 14 '14 at 3:22
@spuder yups. all already ok. the only i need to let the machine ping the 10.236.xx.xx ip using the LAN network. not the Wireless network. – user315384 Apr 14 '14 at 3:24

If the source computer with LAN interface is configured with IP:, netmask

And if the destination is:, netmask

And if there is a router between these two networks, then you have to add a route to the network via your gateway on your source computer:

route add mask

If there is no router between the two networks, and they are directly connected, you have to use netmask on both computers to get what you want.

If this doesn't help, print out the following from both your source and destination computers:

route print
ipconfig /all
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.