Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Both are Windows 8.1 in local network. Remote access is enabled, firewall rule is enabled:

enter image description here

Nevertheless, I am unable to RDS into this computer if firewall is running. I can RDS into if I turn of the firewall.

What to do?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

The firewalls rules in Windows aren't that clear. You see the "Public" rules, right above the ones you have highlighted? Those also apply when Windows thinks it's on a public network. To test, try enabling those rules. If you can now RDP to your computer, then that's the problem.

Depending on what you're trying to accomplish, you've got two options:

  1. Leave the Public rules enabled. If you frequently need to RDP into your computer on different networks, and your machine doesn't have weakly protected accounts, this may be a completely reasonable option.
  2. Tell Windows that the network it's on is actually a private network. The exact nature of this depends on the version of Windows, and I unfortunately don't have a Windows 8.1 box available to check on, but you should be able to toggle this by going to whatever the Network Connections control panel is currently called, going to the relevant connection's Properties pane, and changing the network type to Private.
share|improve this answer
    
solution 2 is preferable, actually the only solution (if the OP is in his protected Lan!). Solution 1 just weakens the public side. They are separated for a reason : The "public" networks can host amongst its users some that could be malicious and attempt to gain access : it's BAD to have too many open ports in an unsecured network (such as any other networks than your own protected Lan). Having good passwords, antivirus, IDS, etc is also required, but won't protect in all cases, if you leave many holes opened in the firewall itself (allowing attackers to try many more vulnerabilities) –  Olivier Dulac Apr 14 at 17:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.