Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a folder tree which is a checkout of Subversion project with a bunch of Office documents in it. I have added it to my Libraries \ Documents, which is handy. However, being a Subversion project, each folder in the tree has a hidden folder called .svn.

Unfortunately, Windows 7 does not seem to respect the hiddenness of these folders, so when I arrange by 'Date modified', I see loads of all-wcprops and entries files, which are found within the hidden .svn folders. I have double-checked that these folders are still hidden.

Setting the files themselves to hidden does not remove them from the Library either. In any case I don't think this should be necessary. I have also set my options to always hide files and folders, and it still shows them in the Library.

Does anyone know how to get the Libraries feature to ignore hidden files and folders?

share|improve this question
    
I don't see any indexing options to exclude hidden files. hmmm... –  invert Nov 23 '09 at 11:44

2 Answers 2

This happens if you have the explorer option enabled to show hidden or system files.

To explain further: Start -> "Folder Options" -> View tab, see the options for Hidden files and folders. If they are set to show, they also show up in search results.

share|improve this answer
    
As I mentioned in the question, I have set this option to not show hidden files and folders. They still show up in the Library. –  Kief Nov 24 '09 at 13:01
    
I created two text files, one normal and one hidden. The hidden file only shows if that explorer option is enabled, and shows/hides each time the option is toggled. I can't recreate this behavior. –  invert Nov 24 '09 at 15:12

I had exactly the same problem with Mercurial repositories. Another way around the issue is to change the Windows Indexing service options to filter out the specific .hg or .svm folders.

You can do this from the Control Panel, Indexing Options. Unfortunately you have to filter each folder individually.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.