Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I am using a Alienware mx14 and am unable to eject the hard disc from my laptop .

I have tried to right click and eject but i get the following error message :

enter image description here

I have tried the following from solution but it does it work also.

Is there any other way to eject my disc ???

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Raystafarian, Kevin Panko, harrymc May 24 at 7:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
You could try to reboot the computer and repeatedly press the eject button during boot. That's what I do when I get this problem, also me not being able to eject under normal conditions is due to bad media and drive spinning continuously, which seems to be different with your case. –  bonob Apr 16 at 15:29
    
@bonob my laptop doesnt have a eject button :( –  Computernerd Apr 16 at 15:30
    
There may be a tiny hole in the outside of the drive tray. If there is, put a paper clip in there to eject it. –  EBGreen Apr 16 at 15:35
    
The dell engineer in that 'Solution' must be a complete idiot. You can see clearly by the pictures on alienwares website that it has no eject or emergency eject buttons and he's saying to eject it via the bios??? What an idiot. Anyway, you could try booting into Ubuntu from a USB stick and eject it from there. You can then determine if it's the media or the drive that is at fault by using different discs. –  Simkill Apr 16 at 15:42

3 Answers 3

Look closely and see if there is a pinhole button next to your drive. If there is stick a pin down there and push it in to eject.

If not, you could boot onto another operating system like Ubuntu and eject from there.

Hope that this helps!

share|improve this answer

Try to eject using a pin on the pinhole of your DVD drive. It should be somewhere near/around the eject button. Insert the pin and push to eject.

Always worked till permanent fix provided.

share|improve this answer

Insert this code into a notepad text file and name it "openDiscDrives.vbs"

For Each d in CreateObject("Scripting.FileSystemObject").Drives
WScript.sleep 60
if d.DriveType = 4 then
    CreateObject("Shell.Application").Namespace(17).ParseName(d.DriveLetter & ":\").InvokeVerb("Eject")
end if
next

Then double click this file, if all your CD/DVD drives don't open then Windows has an issue referring to your drive for some reason, update windows. If this does not work, try re installing your DVD Drive drivers, if that fails then you MAY want to re-install windows.

If it fails after that, you will need to talk to the customer support for your Laptop Manufacturer.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.