Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

everybody.

I'm trying to use bindfs to mount a partition with access for the two users I have in my PC.

I installed bindfs from repository: bindfs 1.12.2

I created a mountpoint called /srv/compartidopre (permissions:0700, user:root) and added this command to /etc/fstab:

UUID=185b927b-56cb-4fdf-9914-76883b593b02 /srv/compartidopre ext4   defaults        0       0

So far so good... it's working ok... but obviously I need to be root to access it.

I created a group called "compartido" and added my two users to it.

Then I run this command:

sudo bindfs -o perms=0770,mirror-only=@compartido,force-group=compartido /srv/compartidopre /srv/compartidopre

It works ok!

Finally I added this last line to the /etc/fstab file:

bindfs#/srv/compartidopre /srv/compartidopre fuse perms=0770,mirror-only=@compartido,force-group=compartido 0 0

But on the reboot the directory /srv/compartidopre it's not accessible to my users.

If I run this command:

sudo mount -a

...the directory is mounted ok and I have access from my user...

What am I doing wrong?

Thanks.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.