Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently switched from Comcast cable Internet to Verizon DSL and can no longer access my company's VPN. The DSL modem is a Westell 6100G. When I connect directly to the DSL modem I have no problems accessing VPN.

However when connected to the Linksys router (either wired or wireless) I can't access VPN. I had the same Linksys router set up when on Comcast and had no problems. The only non-standard setting I have is the Linksys router issues IP addresses with a base of 192.168.2.100 rather than the default 192.168.1.100. I set it up this way because the modem and router were both defaulting to 192.168.1.1 so I switched the router over to 192.168.2.1 to avoid the conflict. What can I check or what settings should I change?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

(1) The Verizon DSL modem/router CAN NOT access the different sub nets. That is, 192.168.2.1 and 192.168.1.1 have to be routed to each other through the gateway of your Linksys router. Now to stop this and have a extention of your DSL router, you need to turn off DHCP for your Linksys router. WARNING: this will in effect turn off the ability for you to go to the Linksys router web page (you can fix it by doing a hard reset (hold the rest button for five seconds on the router)).

Now the most important part. Remove the Ethernet cord going from the Internet port of the DSL to a regular port from the Linksys. With this configuaration the DSL will now give you IP address and DNS entries. You can use the DSL routers configuartion page to do all of your port or routing needs.

(2) The other need way is for you to add persistent routes in a command prompt. Example: If your IP address is 192.168.1.100 then your gateway is 192.168.1.1 and you need to route the second gateway to your computer at 192.168.1.1. so you would bring up a command prompt and type

route add 192.168.2.0 mask 255.255.255.0 192.168.1.1 -p

This will add a persistent route for all incoming trafic from any IP address from the 2.x network (you have a 192.168.1.1 and a 192.168.2.1 gateway so they need to communicate). (1) I urge you to just turn off the DHCP on your Linksys, then plug the cord to one of the four ports, not the Internet port. This will basicly extend your DSL router and the wireless. If you do this to the network, it will look like you plugged in directly to the DSL, and it should work just fine.

share|improve this answer
    
that worked, thanks. –  shsteimer Nov 23 '09 at 17:49
    
two routers means trouble.. only keep one dhcp and your network can grow and grow. –  mike Nov 23 '09 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.