Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I Have a Dell XP 15, Chrome 34.0.1847.116.

When using two finger swipe on the touch pad in order to scroll, the tab wouldn't accept keyboard presses anymore, e.g. the Backspace wouldn't go back, Ctrl+f wouldn't open find bar.

There is an open bug in the Chromium project, but I am not sure if its related to Chrome or to Windows / drivers (I use latest Synaptic drivers.)

In Internet Explorer, the behavior is usually fine.

Any ideas how to fix ?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Also like Ofiris, I did not have these records (#2 and #3 in speedplane's post) in my registry. But on blind faith, I added these entries in RegEdit.

Also, step #4 above is not necessarily visible for all users afflicted with this issue, as it wasn't for me. So even after turning stuff visible, I wasn't able to see these controls. Fortunately, from https://code.google.com/p/chromium/issues/detail?id=361942#c38, htwiz2002@gmail.com was able to document the equivalent of step #4 in the registry, which is

[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh] "GlobalScrollingConfig"=dword:00000009

That did it for me!

share|improve this answer
    
I applied the .reg file in the link, restarted, and all seems to be well now. –  Ofiris Sep 5 at 18:33
    
Awesome! Good to hear. –  Paul Lin Sep 10 at 18:07

The link you have is only one step from the answer. On #21 it links to the original bug report, whose #85 gave a solution.
Credit here on #85

This works on my machine:

  1. Win+R regedit
  2. under HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\Dialog\1Under pointer, change visibility to 0
  3. under HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\Dialog\2Selected item, change visibility to 0
  4. Control panel -> Hardware and Sound -> Mouse -> Device Settings Tab -> Settings (which opens the Synaptics setting page) -> Select Scrolling -> Click Cog Image to open Scrolling Settings
    Change 'scroll selected item' to 'scroll item under pointer'

That's it. Last month I had the problem on both my Linux and Win machine, but now the problem is gone on my Linux system. If you still have the problem on Linux try to update your chrome, or fiddle with synclient.

This seems to be a problem with Chrome rather than Synaptics. What's described here is only a workaround, and it might affect scrolling experience in other programs.

share|improve this answer
    
I don't have these records in my registry (Windows 8). –  Ofiris May 17 at 15:05
    
Do you have your Synaptics driver installed properly? –  octref May 17 at 15:38
    
Yes, see the other answer. –  Ofiris Sep 14 at 8:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.