Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is the first time I installed Ubuntu(v12.04). I have a HP laptop pre installed with Windows 8. I installed it alongside Windows and the installation was successful. But after the customary restart post installation, the Grub menu didn't show up and the system booted into Windows automatically. This is happening ever since, the grub menu doesn't show up at all and I cannot boot into Ubuntu 12.04.

I was having some problems with the default UEFI settings so I had to disable Secure Boot and enable Legacy for my LiveUSB to get detected in the first place. Does this action cause any problem?

Totally stumped. Please help. Thanks. :)

share|improve this question
    
I'm pretty sure pressing Tab forces Grub to pop up during boot. –  adampski Apr 18 at 14:14
    
I tried. It doesn't show the Ubuntu grub menu. –  Neil Apr 18 at 15:05

1 Answer 1

up vote 1 down vote accepted

Installing in BIOS/CSM/legacy mode was a mistake; you've now got a BIOS-mode installation of Linux and an EFI-mode installation of Windows. This is a problem, and to correct it, you must install an EFI boot loader for Linux. There are several ways to do this, but the two easiest are likely to be:

  • Download the USB flash drive or CD-R version of my rEFInd boot manager and prepare a medium from it. Boot from that medium. It should show boot options for both Windows and Linux. If both boot options work, install the Debian-package version of rEFInd from Ubuntu.
  • Run the Boot Repair tool from an Ubuntu live CD. This should fix the problem at once, but it's a bit riskier than the previous solution because it applies a fix with no initial testing. It usually works, but on occasion it can make matters worse.

If neither of these solutions work, post back with the URL that Boot Repair provides. That will give us detailed technical information on how your disk is partitioned and configured.

share|improve this answer
    
Hey @Rod, I created Boot Repair LiveUSB and while starting the repair tool, it said 'EFI detected. Check settings'. But sadly I don't know what these settings are. Here's the link I got paste.ubuntu.com/7286017 –  Neil Apr 19 at 19:03
    
Also, later during repair, I got a message saying that the system is booted in Legacy mode, and to retry again after switching it off. But when I disabled Legacy, my LiveUSB isn't detected at all. –  Neil Apr 19 at 19:12
    
Your repair is best done in EFI mode, so finding a way to boot in EFI mode is the best way to go. Note that rEFInd will boot only in EFI mode, whereas most Ubuntu live images are designed to boot in either mode, so it can be trickier to do the right thing with an Ubuntu image than with rEFInd. If you really can't boot an external medium in EFI mode, you can use the Boot Repair tool's advanced menu to select an option to rename original EFI boot files and put GRUB in their place. (I don't recall the exact name of this option.) This is an ugly brute-force hack, but it's sometimes necessary. –  Rod Smith Apr 19 at 22:22
    
Hey @Rod, sorry for the late reply. As you said, I disabled Legacy from BIOS. Then in Boot options, I selected boot from an EFI file, selected my USB/EFI/BOOT. EFI. It took me to the GRUB 2.0 command line (I'm clueless why the GRUB GUI won't show, as I'm a beginner and new to terminals). Then I loaded the kernel using the following commands: set root=(hdX,Y) \nlinux /vmlinuz root=/dev/sdXY ro\n initrd /initrd.img boot... Ubuntu 14.04 loaded successfully only to hit with a new problem 'Ubuntu running in low graphics mode. Your graphic settings are not detected' and a whole new command line. :( –  Neil Apr 21 at 8:02
    
Your graphics problems are entirely different from your boot problems, so I suggest you start a new question on them. You can either try sudo update-grub to try to get GRUB to work or install rEFInd to get past your no-menu GRUB problem. –  Rod Smith Apr 21 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.