Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had WAMP server installed on my Win 7 computer. After recent update and reboot Apache stopped working. The wampapache service was not started, when I tried to start it manually from services tool, it showed msvcr100.dll error:

Faulting application path: D:\wamp\bin\apache\apache2.4.4\bin\httpd.exe
Faulting module path: C:\Windows\system32\MSVCR100.dll

I searched thru wamp forums, they said to install windows c++ Redistributable Packagewith needed dlls. OK I installed them, rebooted, reinstalled wamp, rebooted, installed and reinstalled again, rebooted (for 2 days, so I did it many times)

Nothing happens - msvcr100.dll is present in c:\Windows\System32 directory, its size is 755 KB (773 968 bytes). When I start the service I receive in log the same error.

What can possibly be done in this case? I can install and reinstall anything, I just need the server working.

If some more logs are needed, ask, for I don't know what to attach.

Update:

Windows 7 ultimate

MSVCR100.dll:

Version language : English (United States)
      CompanyName   : Microsoft Corporation
      FileDescription   : Microsoft® C Runtime Library
      FileVersion   : 10.00.40219.325
      InternalName  : msvcr100_clr0400.dll
      LegalCopyright    : © Microsoft Corporation.  All rights reserved.
      OriginalFilename  : msvcr100_clr0400.dll
      ProductName   : Microsoft® Visual Studio® 2010
      ProductVersion    : 10.00.40219.325
share|improve this question
    
Is Windows 32-bit? What's the current version of the MSVCR100.dll file? –  and31415 Apr 19 at 18:48
    
I've updated the question –  user15 Apr 19 at 21:02
    
When was last time things were working properly? Have you got any restore points? Was the KB2565063 update installed recently? –  and31415 Apr 19 at 21:30
    
2 weeks ago all worked fine (it's a home machine and I seldom use it for dev, so don't sure when all became corrupted, and meanwhile my kids were installed some games). I don't sure regarding restore points, never used them. I did not install KB2565063 as I have no real VC++ installed on my home computer, only free windows Redistributable Packages with dlls. –  user15 Apr 19 at 21:42
    
Just to be sure, open a command prompt and execute this command: wmic qfe | findstr /i /c:"KB2565063" Then post the output here. –  and31415 Apr 19 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.