Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I tried updating to Catalyst 14.4 Beta from Catalyst 14.3 Beta, which just came out today. For some reason the screen went black, with a command line cursor blinking on the top left. It was there for about five minutes at least, so I went to prepare some food. I came back to the same screen about 10 minutes later, so I tried pressing Number Lock, Caps Lock etc, and their corresponding lights were unresponsive. The hard drive light was also not flashing at all, so I did a hard reset using the reset button on my case.

The system booted into the desktop fine, but with Aero disabled and the resolution on 640x480. An error message from Catalyst popped up saying that AMD drivers weren't installed. I decided to run AMD's Clean Uninstall Utility to clean up the graphics driver before retrying the install (That's what they said this was for right...??). During the process, my keyboard and mouse stopped working. I did another hard reset, and it booted into the system, still with the mouse and keyboard unresponsive. I have no idea what to do now -_-... Very frustrating...

  • The mouse and keyboard are both USB
  • Both plugged into USB 2.0 ports
  • Keyboard and mouse won't work on any of the USB ports

Useful specs:

  • M5A99X EVO R2.0 board
  • Sapphire Radeon 7950
  • Windows 7 64 bit Professional

UPDATE 1:

I made a bootable Linux Mint flash drive on another computer, booted into Linux, copied over ALL the files in my installation of TeamViewer (If I only copied over the TeamViewer setup file from their website, I would have to click "run only", or install it for it to run, and tell me the user ID, and password, but I can't exactly do that without my mouse and keyboard) into Windows' Startup folder (C:\Users\**USERNAME**\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup) Reboot into Windows, and hope that TeamViewer is the topmost window that shows up. I took a picture of the window, and is now controlling my desktop from my laptop.

Afterwards, I tried:

  • Reinstalling Asmedia's USB Controller drivers. Freshly downloaded from ASUS' website. Windows says drivers failed to install...
  • Installing chipset drivers freshly downloaded from ASUS' website. No effect...
  • Removed Asmedia's USB Controller drivers, and THEN installing. Still same result as 1st time... (I also reboot after each installation as well)
share|improve this question
1  
Wow, it looks like you are on the right track. I think you must be close to getting the right drivers. You're doing some very solid troubleshooting here. Don't give up. Great job so far. –  allquixotic Apr 22 at 2:54
    
Which error did you get exactly when installing the USB 3.0 controller driver? What do you mean there was "no effect" after installing the chipset driver? Was it installed successfully? Have you got any restore points? Rather than the TeamViewer installer package, you could have used its QuickSupport module instead, which runs immediately without installation and does not require admin rights. Also, this question might be of interest: Bypassing "Found New Hardware Wizard" / Setting Windows to Install Drivers Automatically. –  and31415 Apr 22 at 9:35
    
In Device Manager, the USB ports still show up with the warning triangle with the exclamation mark inside. USB ports still don't work. There's literally nothing changed after installing the USB drivers. Windows just pops up a bubble on the lower right corner saying drivers failed to install. I don't know if the chipset drivers are installed correctly either. There's literally no effect after installing them. The chipset installer just says install successful, and I just click Finish and that's that. No backups and no restore points. Thanks for QuickSupport. I'll try using that instead :) –  Alex Yan Apr 22 at 18:26
    
You could put a batch script into the programs\startup. Lookup to see if there is a silent install options for the drivers package. Or buy another PCI USB adapter board that uses a different chipset. –  David May 3 at 2:25

5 Answers 5

I've seen this problem before.

Unfortunately, when AMD says "ALL", they mean ALL. The AMD Clean Uninstall Utility removes every driver that could possibly support any AMD hardware (including their motherboards and USB controllers; hence your problem), except for the drivers that ship with your basic Windows installation.

I guess the reason why your basic Windows installation doesn't support good-enough drivers for your hardware "out of the box" is that you have a rather new, up-to-date motherboard and chipset. Windows 8 or 8.1 might have drivers that work out of the box, but Windows 7 generally doesn't acquire new "built-in" drivers in updates or service packs. That is to say, Windows 7's continued hardware support of newer motherboards and chipsets is entirely dependent on hardware manufacturers at this point.

That isn't necessarily a bad thing, but it does show that Windows 7, incredibly, is already starting to become an older operating system compared to Windows 8.1. It's not as dead (or undead) as Windows XP, and it's not quite as long in the tooth as Longhorn (er, ahem, Vista -- I just had to throw that pun in there!), but Microsoft is definitely not offering first-class support for Windows 7 on new hardware at this late stage in the game.

Anyway, now you know why the problem happens. The solution is basically to boot into Safe Mode and hope that it will let you install some drivers for your motherboard chipset (which you should be able to obtain either from ASUS, or from AMD themselves). If the install works, you can then reboot and get some semblance of input control back.

Oh, also! Your motherboard should have both USB 3.0 and USB 2.0 ports. Whichever you have your keyboard/mouse plugged into right now, try the other.

As a matter of fact, you might want to try just about every USB port that's available on your system, because high-end motherboards like yours often contain, two or even three separate USB controllers, which can be developed by different manufacturers; you might get lucky and Windows 7 may have built-in support for one of them. But if the fundamental problem is somewhere lower level (such as no driver for the PCI-E bus of your motherboard), your only option may be to get the chipset drivers reinstalled.

Oh, and if the safe mode installation doesn't work for some reason: see if you can't drag out a PS/2 keyboard or mouse and see if you can get that to work. I'd be astonished if it doesn't work; PS/2 is very compatible with old drivers and software.

share|improve this answer
    
Thanks for your input! But unfortunately, Asmedia was the only controller on my board. I tried all the USB ports on my computer, and none works. I thought about PS/2, but unfortunately I don't have any on hand :(. I've tried a few things, but I got stuck again. I'm going to post an update, and hope that more ideas come by soon –  Alex Yan Apr 22 at 2:41
    
Did you try booting into safe mode and installing the driver from there? –  allquixotic Apr 22 at 2:41
    
Yep. Tried it a few times. Can't do much from there :\. TeamViewer doesn't start because Safe mode doesn't start anything that's not required :( –  Alex Yan Apr 22 at 2:57

I had the same issue on the same motherboard (earlier revision though) - USB gets completely dead - regardless of USB 2.0 or USB 3.0)

Solutions:

  • use Windows Restore to get back to the working state of windows, and then use CUSTOM uninstall and uninstall only graphics drivers and CCC (and then install the new package)

  • enable remote desktop and remote to the problematic machine and install the entire AMD package - that should restore USB functionality

  • IF ALL FAILS: I guess the only other option is to re-install OS (painful, but you will end up with a fresh system :)

share|improve this answer
    
Yeah I just ended up doing a complete reinstall as the system refused to boot after a few restarts :(. Then again at least UEFI Windows 8 boots in 5s on my ASUS board now! :P –  Alex Yan Apr 25 at 6:16

I just had this happen as well.. decided to amd clean my amd based system. Windows 7 rebooted and failed to start. I allowed it to run System Repair and that failed as well. In a minor bit of panic, I booted into Safe Mode and ran Windows Restore to the last restore point. My machine is now working properly.

I'm going to go back to my previous method of uninstalling the CCC/AMD driver suite, reboot the machine, suffer with the low res and run Norton Registry cleanup, reboot the machine again and install the latest CCC/AMD drivers. That's been tried and true for me for a few years. No more AMD Cleanup for me, it's bad juju on AMD based motherboards. Good luck!

share|improve this answer

I had the same problem 3 days ago. Just got a 7970 on ebay. Update to amd drivers to 14.1 RC 1. Got an install failure. Tried the AMD cleaner utility, once thay green box came up the keyboard and mouse just stopped. They work in the mobo UEFI bios so i knew it was a driver/windows problem. Did not work in safe mode either.

Had to do a startup repair. Let your PC try to boot into Windows half way then hit the power button to shut it off. Next time you turn it on it will give you startup repair option. Keyboard will still work becuase windows isn't loaded yet. Start up repair loaded an earlier state before the AMD drivers.

It fixed me up. I'm just using the 13.12 drivers now until the next WHQL ones come out.

My mobo is an ASROCK z87 KILLER

Hope this helps.

share|improve this answer

Create a batch script that runs the silent install, put the batch script in Startup folder, put the setup files somewhere sensible.

From the USB driver for this motherboard readme.txt file:

Silent Install/Uninstall All dialogue box will not display when Silent Install/Uninstall

install:      setup.exe /s /v/qn  

ref: http://support.asus.com/download.aspx?SLanguage=en&m=M5A99X+EVO+R2.0&os=8

share|improve this answer

protected by Community May 28 at 1:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.