Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use Zend Framework 2. I have installed the ZendSkeleton Application. When I try to install Framework, I get the following error:

#> php composer.phar install
Warning: This development build of composer is over 30 days old. It is recommended to update it by running "composer.phar self-update" to get the latest version.
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - zendframework/zendframework 2.3.1 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.0 requires php >=5.3.23 -> no matching package found.

So I want to install PHP 5.3.23 on Ubuntu 12.04. Via apt-get nothing happens, so I added a repository.

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ondrej/php5
sudo apt-get update
sudo apt-get upgrade

To be sure I restarted. Still I have PHP 5.3.10.

PHP 5.3.10-1ubuntu3.11 with Suhosin-Patch (cli) (built: Apr  4 2014 01:30:04) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with Xdebug v2.2.4, Copyright (c) 2002-2014, by Derick Rethans

How can I upgrade to 5.3.23 or higher?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

PHP 5.3.10 is the latest version the third party PPA provides. If you want the latest PHP 5.3, you need to download it from php.net and compile it from source.

I would however recommend you use at least PHP 5.4 since 5.3 is only supported until July 2014. Or, if you can afford it, use 5.5 right away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.