Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This might be an impossible question to answer remotely but I figure there may be some common causes that people can suggest so I think it's worth asking...

Video no longer plays smoothly on my laptop. It used to but not for a while now. For example, playing a video on YouTube is pretty typical: I press play (making sure it's not on HD or even HQ) and the video buffers a little then starts to play. At first it plays fine then the video starts to stutter, turning into a slideshow while the sound continues to play smoothly. If I try playing the same video on my Playstation 3 (which is linked to the same network) it plays smoothly so it can't be the connection.

Another example is streaming DivX videos. Again, I wait while it buffers and it starts but very soon, instead of a slideshow, this time the video just plays slowly while the sound continues as normal (instantly getting out of sync). Even if I let the video fully load before pressing play (i.e. it's no longer streaming), it still behaves the same way. I can even let it load 100% then save the file to hard disk and use VLC player to view it, and the same thing happens.

I'm using an old laptop running Windows XP. For the past several years it's been connected to the router via Wi-Fi but in the past few days I've changed that to a network cable (like my PS3) but that hasn't helped. Yes, I regularly install various bits and pieces of software but nothing that I can identify as being the cause.

So, are there known causes of this sort of behaviour and if so, what can I do to fix it?

Thanks.

Update to answer a few questions...

Laptop Spec' (note: video has played back fine for the majority of time I've had the laptop)

  • Toshiba Satellite 1900-603 (possibly called something else outside the UK)
  • Intel Pentium 4 2.2 Ghz Processor
  • Originally had 512Mb memory but recently doubled that to 1 Gig of memory
  • Graphics: ATI Mobility Radeon 16Mb DDR VRAM
  • Windows XP SP3 (Home edition)

Over the years I've done several things to speed it up (disabling indexing etc) and am generally happy with the performance. I also regularly have a clear out of old software (if for no other reason than the laptop only has a 40Gb hard disk) and use CCleaner and Glary Utilities to strip out much of the crap from my system.

Also recently (after doubling the memory), I've tried a few new things which might be likely candidates for slowing the video down such as Rocketdock, Jingle keyboard (which gives an old style 'clacky' typewriter sound when I type - love it), SugarSync, Taskbar Shuffle. However, the video doesn't play smoothly even when I try quit all these apps.

share|improve this question
    
Browser? Why are you still using DivX? –  Phoshi Nov 23 '09 at 22:11
    
When is the last time the OS has been reinstalled? –  Troggy Nov 23 '09 at 22:54
    
Did you update video drivers recently? If yes - try looking for the even newer 'fixed' version. Please check if a different video player (try mpc-hc.sourceforge.net Media Player Classic) also has these problems. I'd also ask if you had any codecs installed recently, but VLC uses internal codecs, so that shouldn't be a problem... –  chronos Nov 23 '09 at 23:19
    
Answers: 1 - Currently using Chrome dev edition but have used several recently (Explorer, Safari & Firefox) while trying to decide which to stay with. 2 - I'm using DivX as that's the format the files use that I'm streaming. 3 - I've never reinstalled the OS. 4 - I've not updated video drivers for years, possibly ever. –  andygrunt Nov 23 '09 at 23:35
1  
Updating drivers is always a good idea, reinstalling the OS would probably help, but is a bit of a big step for laggy video. –  Phoshi Nov 24 '09 at 15:21

7 Answers 7

In my experience, something has changed that is causing the machine to become just a bot more resource limited and you are only noticing this when you view video, which is pretty resource intensive. Just because you haven't installed 1 major resource hog, doesn't mean the same affect can't be achieved by installing lots of little resource hogs. Areas I typically target first:

  1. Add / Remove programs. Remove old just you're not using. It's amazing how it adds up.
  2. Look at the continuously running applications in your task bar. Java console, print monitors, every developer on the planet thinks their cheesy program is the most important thing you'll ever run & feels like it belongs permanently running with a little blinking status icon on the taskbar. Printer software is the worst. Don't ever intall printer software unless you can't print without it.
  3. Startup programs. Seek & destroy anything you don't need.
  4. More ideas here and here.
share|improve this answer

Check out task manager or even better Process Explorer and see what is using your resources.

I recently had almost exactly the same experience - Media Player had been fine for months but started stuttering on even the smallest locally-stored file. After a bit of digging I found that a recent windows update had given me a new driver for my smart card reader. SVCHOST was tying up 50% of my processor (one whole core) and that was making media player lose out big time. Disabling the device made the problem go away.

Worth looking into, see what is using your resources.

share|improve this answer

did you try to use a smaller resolution. IE 800x600 if you have a HIGH resolution IE 1280x1024 the video card on there is not fast enough to render a large picture so full screen it will get choppy. lower the res and get back to me.

share|improve this answer
    
The max res' of the laptop is 1024x768 which is what I've always run it at (inc. when it was running smoothly). I haven't tried it at 800x600. I'll give it a try as a test but wouldn't want to run it like that permanently. –  andygrunt Nov 24 '09 at 16:12
    
Just tried changing res' to 800x600 and get the same result. I also have a TV Out socket connected to my TV showing an extended desktop (had it like that for years) - I tried turning that off at both 1024 and 800 and it didn't make a difference. –  andygrunt Nov 24 '09 at 16:28

Two possible solutions come to mind;

First use Tcp Optimizer to correct any fault in the network settings.

(Install then click Optimize connection, making sure you have the network device in use selected)

Second, you can install a new codec pack download k-lite here.

With all luck that should correct your issue.

share|improve this answer
    
You are trying to treat the symptoms instead of the cause. –  foraidt Mar 15 '10 at 0:07

I had this issue and it actually was my laptop overheating. Try SpeedFan to be sure. I fixed my issue with some canned air.

share|improve this answer

Reinstall operating system, install each application and test the video after each installation.

share|improve this answer
    
I'm guessing he wouldn't be asking if he was happy to do that. –  MGOwen Mar 15 '10 at 2:00
    
It's also one of the solutions. He can copy his current disk to another partition as ghost disk and install a new system.. if he doesn't like it, he can go back –  Greenleader Mar 15 '10 at 11:28

Assuming you are running your laptop in "Plugged in mode"!

First: Make sure to upgrade Adobe Flash Player often.

Second: If your OS is 32 bit double your installed RAM to 2 GB. If OS is 64 bit double that again to 4 GB (or more if your MB supports it). Remember that your on-board video chip is going to use/share a significant portion of your RAM.

Third: Enable the "Run" app by right clicking on the Start Button and choose "Properties"...and under the "Start Menu tab choose "customize". Then check the Run option. Once done, choose the "Run" option from the start menu and type msconfig. Select the Startup tab and deselect all except those you need. Food for thought! There is no need for ANY program to run at startup other than the OS itself. Unless you use a scheduler to run scans etc..

Fourth: Open Users > Your user name > Application Data > Local > Temp and select ALL and then choose DELETE. There will be a file or two that is in use and you will not be able to delete those. That is OK.

And, last but not least: Make sure you are using the recommended screen resolution for your laptop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.