Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Linux Mandriva 2008 makes a continuous beep sound after installing on Laptop - Dell M2300. How can I stop the sound?

share|improve this question

migrated from serverfault.com Nov 23 '09 at 23:14

This question came from our site for professional system and network administrators.

add comment

2 Answers 2

Maybe I got your question wrong and John T already gave the right answer, but I understood you referred to the system beep, the one you were used to get in the old good days when you would keep a key pressed for too long, under MS-DOS. :)

If that is what you were asking. Then you have to disable the module responsible for that in the kernel (don't panic... it's dead easy!).

From terminal, as root user (or by doing sudo):

modprobe -r pcspkr snd_pcsp

If that solves your problem, than you can permanently tell the kernel not to load those modules anymore and you can adde them to the file

/etc/modprobe.d/blacklist

Hope this helps!

share|improve this answer
add comment

GUI approach:

  • Navigate to System Configuration -> Notifications -> System Bell
  • Set it's volume to 0

command-line approach:

  • Load up alsamixer:
alsamixer -c 0

once it loads, mute the system beep (beep channel):

  • Save the changes:
alsactl store
  • Reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.