Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using Virtualbox (now at 3.0.2) on Kubuntu (now at 9.04) for a while now, and I seem to have a problem when running Windows. Sometime after a while the audio will cut out in Kubuntu. The only way I can get it to recover is to make sure VirtualBox is completely shutdown and either going into multimedia under "system settings" and test the audio or restart.

I'm wondering if anyone else here has experienced similar issues and has come up with a more elegant solution. I can't seem to find a reasonable one at virtualbox.org.

share|improve this question
    
I do not see this enable nested paging. What program are you talking about? Win7 or VB? I do not see it in VB on Linux. –  user62874 Jan 13 '11 at 4:42
add comment

6 Answers

up vote 1 down vote accepted

I've had similar problems with vmware and Ubuntu 8.10. I have since upgraded both the vmware and the OS. I am guessing that the new audio mixer can handle the virtual machine input more gracefully.

I would suggest upgrading to Ubuntu 9.10. If that alone doesn't solve the problem, perhaps upgrading Virtual Box would help.

share|improve this answer
add comment

In the VirtualBox OSE control panel, under the 'Details' tab there is an audio section where you can select different devices for your virtual machine. You can try adjusting these settings.

Screenshot

share|improve this answer
    
Note that newer Ubuntu versions (>8.04) use PulseAudio by default, so you might want to set that as your Host Driver. See also blog.mattrudge.net/2010/03/23/… –  ChrisiPK Dec 17 '12 at 22:33
add comment

I have never experienced audio cut-out in VirtualBox. That sounds like a serious problem... is PulseAudio happy?

However, audio playback has always been choppy and variable (curiously though, VirtualBox's PulseAudio output is slighly less bad for me than straight ALSA), and if anything seems to have been getting worse over the 3.0.x series. It's got so bad I've taken to using REAPER under WINE instead, which I don't really enjoy much.

share|improve this answer
add comment

This worked for me, Windows 7 guest on Ubuntu 10.04 host:

from VirtualBox Website

Control Panel > System and security > Windows Update > 

On the left side, manually select 'Check for Updates'.

'Optional Updates' > 'Recommended' item > 'Microsoft Driver Update for Intel(r) 82801AA AC'97 Audio Controller'.

Select this from the list, and install it.

After this, the sound was skipping. this was fixed by unselecting the "Enable Nested Paging"

settings > system > acceleration > enable nested paging

Good Luck!

share|improve this answer
add comment

I've had a problem with Ununtu 11.04 as Virtualbox host, Windows XP as client OS, and playing radio on Ubuntu. The sound gets scrambled, and the only solution is to close Rythmbox and restart it. Because I don't need sound on the guest, I've disabled the sound adapter completely, and that seems to solve the problem for me.

share|improve this answer
add comment

There was a setting I was able to change that fixed things. In 9.04 ALSA was the default sound support. So, after upgrade, VirtualBox still thought my host platform was providing sound support via ALSA. With 9.10 the default sound support is via PulseAudio. Once I made VirtualBox aware of that change, Windows-based sounds started working well again

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.