Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Aptana to develop a PHP site. I'm a .NET developer with some experience with PHP. I'm used to the highly robust Visual Studio and getting used to Aptana (built on the Eclipse core). When I have several files open I cannot ctrl+tab between them. Does anyone know how to turn that on? It's kind of pathetic if that's off by default.

share|improve this question
    
Have you tried CTRL + E ? –  ukanth Dec 8 '09 at 9:50
add comment

6 Answers 6

up vote 5 down vote accepted

I haven't worked with Aptana in a long time, but I've used Eclipse quite a bit, and I believe the tab-switching is bound to Ctrl+PgUp (or PgDown) by default. I just recently installed Galileo, and used this as an opportunity to try rebinding to Ctrl+Tab, but didn't have any luck.

I know I got this to work on previous versions of Eclipse (at least Europa, and possibly Ganymede), but am not certain why it's not working in Galileo. Regardless, here's how to find the key-bindings in an Eclipse install (I would assume Aptana uses these bindings as well):

Windows->Preferences->General->Keys

From there you can try filtering the key-binding you're looking for (e.g. "tabs" or something) and input whatever combo you want.

I would also recommend searching for the key-combo you're going to use to make sure it's not already in use. If it is, you'll want to re-bind the conflicting binding, so they don't collide.

share|improve this answer
add comment

Go to windows->Preferences->General->Keys. Type Next Tab and select the command "Next Tab" (Category All Aptana Editors). Unbind this command, edit the "Next Editor" command to ctrl+tab and voila!

share|improve this answer
    
This is alright... but it orders them in most recently used, rather than the order of the tabs on the screen, making it very different from similar apps –  philfreo May 21 '10 at 23:22
    
+1 I had the same issue with eclipse on ubuntu. Thanks for the solution. It works very well now :D –  Igor Popov Aug 15 '10 at 5:39
add comment

On my Mac Book Pro running Leopard it's:

CTRL+FN+SHIFT UpArrow|DownArrow

share|improve this answer
add comment

Actually all you need to do is CTRL + PageUp | PageDown

share|improve this answer
add comment

fn+control+up/down on my macbook works

share|improve this answer
    
same for me in laptop or ctrl-pageup when using external keyboard –  Pablo Marin-Garcia Apr 8 '11 at 23:51
add comment

I know this is pretty old. As of today, I've still found a similar issue on Eclipse Juno after installing Aptana Plugin.

Ctrl+Tab used to work in Eclipse (since several versions, by now) before I installed Aptana. After installing Aptana, when hitting Ctrl+Tab I could see a small window flashing in the lower right corner of Eclipse window. That's the small yellow window popping up when you have multiple commands matching the same hotkeys.

There was a conflict on Ctrl+Tab hotkey between Next Editor and Next Editor (Aptana) commands. They both where active when In Windows.
To solve this specific issue, I just changed the Next Editor (Aptana) hotkey to be active when In Aptana Editor. HTH

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.