Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since my update to Ubuntu 14.04, I cannot connect to the companies git server. It uses https with the SSL protocols only. When running git clone (or any other git command that connects to the server) I get the following output:

$ git clone https://git.my.company.com/repository.git
Cloning into 'repository'...
fatal: unable to access 'https://git.my.company.com/repository.git': gnutls_handshake() failed: A record packet with illegal version was received.

I had a similar problem with mercurial (same company server), which I 'fixed' by disabling the TLS protocols in the mercurial configuration ~/.hgrc:

[ui]
tls = False

I suppose I have the same problem with git, but I cannot find out how to disable TLS for git.

As it seems (from the error) that gnutls is used by git. I tried to disable TLS using gnutls-cli::

$ gnutls-cli "NORMAL:-VERS-TLS1.0:-VERS-TLS1.1:-VERS-TLS1.2" git.my.company.com

This works to establish a connection to the server. Whereas

$ gnutls-cli "NORMAL:-VERS-SSL3.0" git.my.company.com

gives the same error as git: GnuTLS error: A record packet with illegal version was received.

But, there does not seem to be any configuration file (e.g. in /etc/) for gnutls to store the "NORMAL:-VERS-TLS1.0:-VERS-TLS1.1:-VERS-TLS1.2" part for the hostname

So, how can I configure git or gnutls to disable TLS or to force using SSL?

Note: I am not able to modify the server, the ICT staff has plans to upgrade the server (it is quite out-dated hardware and software wise), but that is (probably) not going to happen soon due to the lack of available time...

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.