Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have multiple hard drives. One for programs (C:) and one for data (D:).

My plan was to install Windows 7 on a new SSD drive which would replace my current (C:). Windows 7 wouldn't install onto the SSD for an unrelated reason. So back to XP.

However, when I booted back to XP my data drive (D:) (which I didn't touch) now shows up as a 'Foreign' (Dynamic) disk in Disk Management.

When I try to import the foreign disk, the dialog shows the single partition as 'OK', but when I click OK, I get an error.

This is the error from the system log:

Event Type: Error
Event Source:   LDM
Event Category: None
Event ID:   2
Date:   	11/23/2009
Time:   	11:28:47 PM
User:   	N/A
Computer:   SILENTBOB
INTERNAL Error - A disk group with the specified name already exists  (C100007A).

And just prior to that error, is this warning:

Event Type: Warning
Event Source:   LDM
Event Category: None
Event ID:   1000
Date:   	11/23/2009
Time:   	11:28:47 PM
User:   	N/A
Computer:   SILENTBOB
Disk group SilentbobDg0: Two disk groups have the same name

The disk won't import.

How can I fix this? Thank you for any help.

share|improve this question
up vote 3 down vote accepted

To work around this issue, we need to modify registry. If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly.

If your system/boot drive is still a basic disk, follow these steps to correct this condition:

  1. Start Registry Editor (Regedt32.exe).

  2. Click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dmio\Boot Info

  3. Under the Boot Info key, delete the "Primary Disk Group" key.(you need to delete the CORRECT key for your DISK)

  4. Quit Registry Editor, and then reboot the computer.

  5. After the reboot, try to import the foreign disks again.

Source: Cannot import foreign disks!

Please try the suggestion above and let me know the results.

share|improve this answer
That fixed it. Thank you. After deleting the "Primary Disk Group" and rebooting, the disk automatically showed up (no import required). This worked for my dynamic disk even though the steps above say "is still a basic disk". – Jon-Eric Nov 24 '09 at 14:53
no Problem!! glad it worked! – mike Nov 24 '09 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .