Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The motherboard I'm using is Gigabyte H67M-D2-B3.

When I was using my old Graphics Card (Sapphire HD 6850), my computer crashes once in a while quite randomly/unpredictably. Sometimes BSOD related to ntoskrnl but caused by atikmdag.sys. Sometimes my screen just plain out freezes and everything stopped working then it'll just reboot if I leave it alone after a minute or so.

I've upgraded to Sapphire R9 290 now and the problem persists. Similar crashing scenario and sometimes, my sound card (Asus Xonar DX) suddenly stop working as well while I'm using my computer.

My question is, can a motherboard's PCIe slot fail while everything else still works fine?

I can get back to using my computer usually after a reboot or a few reboots. Sometimes I need to give my Graphics Card a little wiggle and if I reseat my graphics card, the problem wouldn't persists again sooner than I didn't reseat my graphics card.

PSU: Corsair TX 650M

Components: Single CPU, single GPU, 2 HDD, 1 SSD, 2 sticks DDR3, 1 sound card all running stock (no overclocks)

share|improve this question
Check what is connected -- your PS seems adequate, but that all depends what else is connected to it. Also try adding a case fan or two (even if temps seem OK in testing). – Debra Apr 27 '14 at 16:49
I've already listed all the major components in my question. My case is moderately ventilated. Originally had only 1 exhaust fan which came with my Case (Cooler Master Elite 370) but added 2 more intakes. 14cm on the front and 12cm on the side for fresh air directly onto the graphics card. The most weird thing is it happens not only when I'm gaming, regular web browsing too! – josephting Apr 28 '14 at 17:30
I hope you understand that info like "2 HDD" doesn't really tell what the drives draw; you have to check the mfr's site for power consumption. Your PS could be marginal and also could simply be flawed in maintaining even one of the voltages. The on-board GPU could be overheating, CPU might not be cool enough (80C is marginal for many.) It's very unlikely for the PCIe slot itself to fail; it's more likely to be the usual suspect components. Have you checked the hard drives as well, and tested with lower graphics settings (resolution & color depth)? – Debra Apr 30 '14 at 0:58
It is 1 WD Green and 1 WD Black. Yeah, PSU might be close to its limit but the same PSU is causing similar issue on a HD 6850 instead of a R9 290. On-board GPU is disabled if PCIe graphics is detected, CPU is much cooler than GPU (>10C cooler under load). HDD are working fine, no file corruption and perform normally. It is extremely random for the problem to reproduce, what good would lower graphics settings do? – josephting May 1 '14 at 5:52

1 Answer 1

up vote 1 down vote accepted

Yes, it can. The most common way a slot can fail would be physical damage to the slot causing it to make poor contact with the card edge.

But rather than jumping to conclusions, I'd suggest you troubleshoot your problem without making any assumptions. Start by running memtest86+ for several hours.

share|improve this answer
How many passes for a memtest to be sufficient? I've already done this before I upgrade to R9 290 and it passed once or twice without any error. – josephting Apr 27 '14 at 8:50
One full pass is sufficient. I'd move on to inspecting hardware next. Make sure all fans are working, there isn't excessive dust, and so on. – David Schwartz Apr 27 '14 at 8:51
Thanks for your help. I did and the temperatures are <= 50C idle and < 80C under load. I think I'll just bear with this and upgrade when DDR4 is available. :D – josephting Apr 27 '14 at 8:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.