Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I do ping on the host (Win7) I get and am able to ping without issue.

When I do ping on Ubuntu (my VirtualBox guest OS) I get a connect: Network is unreachable message.

Here's the output of ifconfig:

enter image description here

I've tried doing sudo ifconfig eth0 down and then sudo ifconfig eth0 up and they appear to run without issue. What's interesting is that ping actually worked before I did the ifconfig stuff. Doing it in fact seems to have in fact made things worse - not better.

Doing cat /etc/resolv.conf gives me the following:


Here's a copy of my virtualbox settings:

enter image description here

Any ideas?

share|improve this question
Try sudo dhclient eth0, and see whether you can connect. – MariusMatutiae Apr 28 '14 at 16:33

1 Answer 1

I would recommend installing the VirtualBox additions inside the VM. This will provide drivers to the guest OS to use the adapters provided by VirtualBox.

Another option I'd recommend is using the "bridged adapter" instead of NAT.

It could also be that the ARP table got corrupted while you were changing settings. You can try clearing the ARP cache using THIS as a guide.

Since you're using a live CD, you can restart and the settings all revert back to normal.

share|improve this answer
I'm running an Ubuntu LiveCD. I'd have to eject the CD (which would probably kill the OS) to insert another one containing the VirtualBox additions.. – neubert Apr 28 '14 at 16:01
Then try the bridged adapter setting and see if that works. – Colyn1337 Apr 28 '14 at 16:07
I did - didn't help :( – neubert Apr 28 '14 at 16:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.