Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the settings correct - just to make sure: - Tools | Options | Preferences Tab | Email Options | Advanced Email Options the Display a New Mail Alert is checked.

It doesn't work When I click Preview.

I also use rules for emails delivered in other folders than Inbox to display the alert and I have the same problem. However, the envelop is displayed in the tray.

I think the problem started since I upgraded to SP2, not sure ... (it worked fine until 1-2 months ago).

Is there an workaround for this?

share|improve this question
up vote 4 down vote accepted

Could it be that the alert is being displayed off-screen? If you're comfortable with editing the registry, you can navigate to:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts

and set the "XOffset" and "YOffset" values to zero (or near-zero). If that doesn't help, you may also try to delete the "Corner" value if it exists.

share|improve this answer
1  
Thanks! I've been playing with the XOffset and YOffset values before and it didn't help. Deleting the "Corner" entry fixed the problem! Thanks again for your help! – Nicu Zecheru Nov 24 '09 at 18:34
    
Just curios, do you know how this happened, was it due to SP2 update? – Nicu Zecheru Nov 24 '09 at 18:35
1  
I can neither confirm nor deny that SP2 would do something like this, but I believe a lot more people would have experienced the same problem if that were the case. Usually such incidents occur if you've been using a secondary monitor, and the application remembers the last window position even after you unplug the secondary monitor. If you've never used a secondary monitor, I have no clue as to why this happened :) – Terje Mikal Nov 24 '09 at 18:48
    
Yeap, I also used a second monitor, this might be it. – Nicu Zecheru Nov 24 '09 at 18:50
    
Thanks, addig XOffset and YOffset solved my problem. Using a second monitor... – pihentagy Nov 18 '11 at 16:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .