Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just updated to Firefox 29 today, and now there's no Control Menu (Firefox icon). In fact, the entire Title Bar is now missing.

Here's how it looks in Firefox 29 (NOT what I want):
Firefox 29

And here's how it looks on my other computer (Firefox 28 which I haven't updated yet). This is what I want:
Firefox 28

How can I at least get the Control Menu back?

share|improve this question
3  
I didn't update myself, but did you give addons.mozilla.org/en-US/firefox/addon/classicthemerestorer a shot? –  Patrick R. Apr 28 at 21:16
    
What OS are you on? I don't have a Control menu on 28 either; I have the big Firefox menu button (Windows 7). –  w3d Apr 28 at 21:18
1  
I'm on Windows 7. –  MTS Apr 28 at 21:21
    
@Patrick R. - Thank you Patrick. The "Tabs in titlebar" option in the Classic Theme Restorer works. It also led me to the about:config setting that I've posted as an answer below. –  MTS Apr 28 at 21:27
1  
FWIW Alt+SpaceBar is the keyboard shortcut for the "Control Menu" and this seems to work whether the icon is visible or not. –  w3d Apr 28 at 21:27

5 Answers 5

up vote 12 down vote accepted

To get the control menu back in Firefox 29 on Windows:

  1. Click the "Open Menu" (far right with the three horizontal bars)
  2. Click "Customize (bottom of the opened window)
  3. Click "Title Bar" (bottom left of the opened window) This toggles the top control menu on and off.

Screenshots

a b

Click on image for a larger view.

share|improve this answer
    
Awesome, thank you Mike! That's really easy. This is the correct answer in my opinion. –  MTS May 1 at 21:29
    
This is very neat! It's much easier than the about:config method. Even though both methods do the same thing, I would prefer this one. –  sammyg May 5 at 16:05

Ok, this seems to work. Change the Firefox browser.tabs.drawInTitlebar setting to false.

  1. Type about:config in your address bar.
  2. Search for browser.tabs.drawInTitlebar.
  3. Double-click to change value to false.

As Patrick R. pointed out, you can also use the Classic Theme Restorer add-on (addons.mozilla.org/en-US/firefox/addon/classicthemerestorer), and uncheck the Tabs in titlebar option. x

share|improve this answer
2  
There is a simple way to change this setting without the need for about:config or an addon, as explained in this answer: superuser.com/a/747791/246852 –  cremor Apr 30 at 9:42
    
@cremor - Agreed. I've marked that as the answer, above. –  MTS May 1 at 22:18

To show the title bar without showing the menu bar, open about:config, search for browser.tabs.onTop and make it false.

Now the tab is on bottom, but the title still isn't shown. You need to install the add-on Display Window Title to make it visible. That's what I'm using now

Firefox title bar

After that you can right click at the title bar or press alt+spaceto view the window menu or system menu (not control menu)

share|improve this answer
    
This didn't seem to have any affect with my configuration. –  MTS May 1 at 21:36

One alternative is remove Firefox version 29 and go back to Firefox version 28:

http://download-installer.cdn.mozilla.net/pub/firefox/releases/28.0/win32/en-US/Firefox%20Setup%2028.0.exe

(This link doesn't seem to be anywhere on the Mozilla website that I can find).

share|improve this answer
    
Update: And various other versions can be found at ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0 –  Joseph Quinsey Apr 30 at 4:18
    
Update: And Mozilla does have a link here: support.mozilla.org/en-US/kb/install-older-version-of-firefox –  Joseph Quinsey Apr 30 at 4:45
    
I've tried this in the past with an older version of Firefox, and after about two weeks Firefox auto-updated itself to the newest version anyway, even though I had automatic updates turned off. Even if this wasn't the case, staying with an old version doesn't seem like a feasible long-term solution. –  MTS May 1 at 21:33
1  
Of course, Mozilla Firefox is not Google Chrome. Unlike Google, Mozilla supports one to two previous releases of their web browser, and they make all previous versions of the browser available for easy download through their FTP server. –  sammyg May 5 at 16:00

Apparently, Mozilla has decided to get rid of the big orange Firefox button in the upper left corner, starting with Firefox 29.0. It has been replaced with a "Open menu" button on the right hand side, underneath the window close (x) button. This placement follows the foot steps of Internet Explorer (the gear icon), and Google Chrome. It actually resembles the menu button of Chrome 34, they almost look identical.

To get to "control menu" regardless of UI design

Regardless of what the UI looks like, try this keyboard shortcut to get the same result:

Alt+Space

You can use this in pretty much any program window in Windows. It works in Windows Explorer or File Explorer, CMD, or even programs that use their own window themes like Wunderlist or Spotify. So if you press this shortcut in Firefox 29.0 this is what you will get:

e

You can follow that up with C key to close the program window. (It will be a different key if you're Windows is not in English.) If all you want to do is just close the program window, you can always use the trusty old Alt+F4 and that will close it, without having to open the control menu.

share|improve this answer
    
No, that's not what I want. I want the Title Bar to be visible (or at least the Control Menu), not the Menu Bar to be hidden. –  MTS Apr 28 at 21:20
    
Normally (before version 28 at least) disabling/unchecking the "Menu Bar" removes the Control Menu? –  w3d Apr 28 at 21:24
    
@MTS Then what do you mean by "Control Menu (Firefox icon)"? What do you mean by "Control Menu"? And is "Firefox icon" a reference to the Firefox favicon as seen in your screenshot? –  sammyg Apr 28 at 21:24
    
@sammyg - Please see the red arrow pointing to it in the first image in the original question. –  MTS Apr 28 at 21:32
    
@sammyg - Are you even using Firefox 29 because the screenshots your using look nothing like mine. Interesting enough the Menu Bar looks out of place when the window is active although that might be my Windows theme doing it. –  Ramhound Apr 28 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.