Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Previously, in 9.04, I was using pam mount in conjunction with encfs to mount an encrypted volume at login. This worked perfectly and since the password was the same as my user password, none was entered besides the initial login one.

Now in 9.10, using the same setup and the same volume line in pam's config file, the volume will not mount. The folder does not even get created for the mount point. I am thinking this might be caused by the fact that I now switched to using an encrypted /home directory (previously left unencrypted on 9.04). To encrypt it, i used the standard /home encrypt setup from the 9.10 fresh install.

I am thinking that perhaps, pam tries to mount the volume before /home is mounted and fails. Is there a log file I could look into/post here?

Note that mounting manually works fine using the same paths, writing full paths does not help, nor is removing the options attribute.

Here's my volume entry:

<volume user="nicholas" fstype="fuse" path="encfs#~/.dropbox_dir/Dropbox/encrypted" mountpoint="~/Dropbox" options="nonempty" />
share|improve this question

Concerning the sole question, how to automatically mount an EncFS volume at login in Ubuntu, you might have a look at gnome-encfs which uses GNOME's keyring and autostart to mount EncFS folder automatically.

An advantage to pam-mount is that gnome-encfs also works with EncFS folders/volumes with a different password than your user account. A disadvantage to pam-mount is the GNOME dependency. Auto-mount only works when logging in to a GNOME session.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.