Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My user home folder does not display in the Windows Explorer file tree. I have things like Libraries and Favourites, but my user profile folder isn't there. I know it can appear there because I had it there when I was using Windows 7 RC.

How do I get it back?

See below for the evidence that it exists, yet does not appear promoted to the top level of the tree, like it should be:

alt text

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Browse to "Users" In the right hand pane grab your "Dell" user folder, drag it to the "Favourites" and drop (you will see a prompt to create a link in Favourites before you let go)

share|improve this answer
    
That's good enough I guess. I wish I knew how to promote it to the top level of the tree though... –  Nathan Ridley Nov 25 '09 at 10:44
    
I don't know a way to get it promoted up a level, but you can get it nearer the top of your favourites list simply by dragging - you can sort the favourites by name, but you can manually set it to any order you like by dragging items around. –  AdamV Nov 25 '09 at 12:51
    
Colin's answer about "Show All Folders" is what the OP was actually looking for. This is just a workaround. –  Sam Hanes Apr 24 '13 at 20:01
    
Good call, I've upvoted –  AdamV Apr 24 '13 at 23:21
add comment

To see your user name as a folder:

  1. From the Explorer toolbar click Organize,
  2. Folder and Search Options,
  3. Check "Show All Folders" in Navigation Pane.

This will give you a Desktop folder, and put everything but Favorites under it, including your user directory. (You can also right click in the Folder Pane itself, but it's tricky because it only works in the margin space. Right click the margin space between Favorites and Library because you want the context to be the pane, not any folders under the cursor)

(I know this is an old question, but I had the same issue, and I've found the solution, so I thought I'd post and help the next person out.)

share|improve this answer
add comment

If Libraries and Favorites are there, then your user profile is still there.

EDIT

Right-click Documents and choose Properties to see where they are.
(You might also do that to Downloads.)

It should give something like:

image

Please post what are these values.

share|improve this answer
    
Yep, see my edit above. –  Nathan Ridley Nov 24 '09 at 16:52
    
Please answer my edit. –  harrymc Nov 24 '09 at 19:30
    
Exactly what you posted above, but "Dell" instead of "harry" –  Nathan Ridley Nov 25 '09 at 10:45
    
Well, then you're suffering from an infestation of Dell : "Dell" IS your profile name. See "How to rename or move a User Profile folder" at fixya.com/support/r463850-rename_or_move_user_profile_folder. It's for Vista but is probably the same for Win7. –  harrymc Nov 25 '09 at 11:12
    
My issue was not the fact that it was named "Dell", but that it was not referenced from the top of the explorer tree. I don't really care what it's called... :P –  Nathan Ridley Nov 25 '09 at 17:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.