Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to play a DVD on Ubuntu 9.04. I've played DVDs on this machine before, but not with this OS. I've read this page, and libdvdread4 and libdvdcss2 are both installed:

$ dpkg -l libdvdread4 libdvdcss2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  libdvdcss2     1.2.10-0.2medi Simple foundation for reading DVDs - runtime
ii  libdvdread4    4.1.3-4ubuntu2 library for reading DVDs

I've tried both totem-xine and vlc. Totem shows the name of the disc in the menu (progress!), but trying to play it shows a dialog box "An error occurred: The source seems encrypted and can't be read. Are you trying to play an encrypted DVD without libdvdcss?". VLC simply does nothing at all in the UI.

Both log some info to stdout/stderr. They have slightly different libdvdnav versions, but both display exactly the same CSS info:

libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: DVD Title: SHINOBI
libdvdnav: DVD Serial Number: 359632fa
libdvdnav: DVD Title (Alternative): 
libdvdnav: Unable to find map file '/home/ken/.dvdnav/SHINOBI.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000137
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x00000817
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000c41
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0002cfca
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0002e419
libdvdread: Elapsed time 0
libdvdread: Found 2 VTS's
libdvdread: Elapsed time 0

to which Totem also adds:

demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.

though it doesn't seem related.

I tried another DVD, and it worked fine (in Totem, anyway). It's a homemade DVD from camcorder footage, with no menus or chapters. Update: another commercial DVD works fine here -- the second DVD from this 2-DVD set, in fact, so same region, same studio, etc. I also tried my first DVD on a different machine (with a different OS), and it plays fine there, so it's not simply a bad DVD.

Is it possible there are DVDs which libdvdcss2 simply can't crack?

share|improve this question
    
Consider making your title more clear to describe what the question is actually about. –  Gnoupi Nov 24 '09 at 16:39
    
You're welcome to change it yourself if you think it'll help. I think it describes exactly what this question is about, which is why I picked that title. –  Ken Nov 24 '09 at 16:58
    
I'm simply not sure what the "...yes, i did that" means, or gives as information, simply. When I said "more clear" or more describing, I meant something recalling the actual question which is at the end of what you wrote. The objective is to give the most detailed (though short) title, so that more people are actually checking the question. It increases your chances to be answered, simply. –  Gnoupi Nov 25 '09 at 9:25
    
"Yes, I did that" is because if you google for "Ubuntu dvd", you turn up about 37 gazillion hits for threads on various forums consisting of exactly 3 messages: "how do I watch a DVD in Ubuntu?", "read RestrictedFormatsPlayingDVDs", "oh thanks". So I figure there's about 37 gazillion people out there whose initial reaction to any Ubuntu DVD question would be that I'm an idiot for not STFW and installing libdvdcss, and I wanted to get that out of the way in the title. –  Ken Nov 26 '09 at 4:12
    
It is not obvious that the addition of "Yes, I did that" is in regards to a typical google search result. The phrase adds a certain attitude to your question that might rub people the wrong way. Might be good to avoid that in the future to get better answers. –  basszero Nov 26 '09 at 19:57

3 Answers 3

I tried a newer version of VLC on a different computer/OS, and it worked there. So I eventually upgraded to Ubuntu 9.10, and even though it has the same version of libdvdcss, it works fine now.

So I have no idea what was going on, but it's gone now. As computer problems come, computer problems go.

share|improve this answer
1  
interesting. sounds like the kind of bug that'd be difficult to pin down to a particular package. was that the only disc you ended up having trouble with? –  quack quixote Nov 26 '09 at 20:28
1  
Please mark this as the accepted answer. –  Diago Nov 30 '09 at 5:37

Since you are able to read other DVDs with the same software, I'd expect the problem with that particular disc is either a) a bug in libdvdcss, or b) a problem with that specific disc. If you can play other commercial discs in this computer (try more than just discs from the same set), it's not a general CSS problem.

Since you state the problem disc can be played in a separate computer, I'd try testing a lot more commercial dvds, and possibly filing a bug against the libdvdcss2 package. If you are comfortable compiling software in Linux, it'd be interesting to know whether the problem disc works with earlier and/or more recent versions of libdvdcss.

share|improve this answer

Is it possible there are DVDs which libdvdcss2 simply can't crack?

Yes, some don't work...


Have you tried to use the packages provided by http://www.medibuntu.org/?

Medibuntu (Multimedia, Entertainment & Distractions In Ubuntu) is a repository of packages that cannot be included into the Ubuntu distribution for legal reasons (copyright, license, patent, etc).

The Medibuntu howto is a good start:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.