Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to type the letters "Ć" and "ć" using the compose key sequences, however, they don't seem to work:

  • Compose,,,C results in a "ç", which is fine
  • Compose,,,Shift+C results in a "Ç", which is also fine
  • Compose,',C (that is, with a small "c") results in a "ç", which is not good, it shouldn't
  • Compose,',Shift+C does nothing, which is not good either, it shuold be a "Ć"

Here's the result of grep "LATIN .* LETTER C WITH CEDILLA$" /usr/share/X11/locale/en_US.UTF-8/Compose:

<dead_cedilla> <C>                      : "Ç"   Ccedilla # LATIN CAPITAL LETTER C WITH CEDILLA
<Multi_key> <comma> <C>                 : "Ç"   Ccedilla # LATIN CAPITAL LETTER C WITH CEDILLA
<Multi_key> <C> <comma>                 : "Ç"   Ccedilla # LATIN CAPITAL LETTER C WITH CEDILLA
<Multi_key> <cedilla> <C>               : "Ç"   Ccedilla # LATIN CAPITAL LETTER C WITH CEDILLA
<dead_cedilla> <c>                      : "ç"   ccedilla # LATIN SMALL LETTER C WITH CEDILLA
<Multi_key> <comma> <c>                 : "ç"   ccedilla # LATIN SMALL LETTER C WITH CEDILLA
<Multi_key> <c> <comma>                 : "ç"   ccedilla # LATIN SMALL LETTER C WITH CEDILLA
<Multi_key> <cedilla> <c>               : "ç"   ccedilla # LATIN SMALL LETTER C WITH CEDILLA

And here's the result of grep "LATIN .* LETTER C WITH ACUTE$" /usr/share/X11/locale/en_US.UTF-8/Compose:

<dead_acute> <C>                        : "Ć"   U0106 # LATIN CAPITAL LETTER C WITH ACUTE
<Multi_key> <acute> <C>                 : "Ć"   U0106 # LATIN CAPITAL LETTER C WITH ACUTE
<Multi_key> <apostrophe> <C>            : "Ć"   U0106 # LATIN CAPITAL LETTER C WITH ACUTE
<Multi_key> <C> <apostrophe>            : "Ć"   U0106 # LATIN CAPITAL LETTER C WITH ACUTE
<dead_acute> <c>                        : "ć"   U0107 # LATIN SMALL LETTER C WITH ACUTE
<Multi_key> <acute> <c>                 : "ć"   U0107 # LATIN SMALL LETTER C WITH ACUTE
<Multi_key> <apostrophe> <c>            : "ć"   U0107 # LATIN SMALL LETTER C WITH ACUTE
<Multi_key> <c> <apostrophe>            : "ć"   U0107 # LATIN SMALL LETTER C WITH ACUTE

This is my keyboard layout:

setxkbmap -layout us \
    -variant dvp \
    -option compose:ralt \
    -option keypad:atm \
    -option numpad:shift3 \
    -option altwin:meta_win \
    -option kpdl:semi

And this is the contents of my .Xmodmap:

clear Lock
keycode 0x42 = Escape

How do I fix the mappings so that I can type ć and Ć using the right sequence?

share|improve this question
    
I can't help you with your question but you might get more responses on Unix.SE. Please follow the guidelines outlined in this Meta Q&A if you are planning to cross-post/move your question. –  Glutanimate May 16 at 18:09
    
Are you actually using the en_US.UTF-8 locale? Also, are you witnessing the same behaviour in GTK+ applications as in non-GTK+ applications (e.g. urxvt)? –  Sam Hocevar May 17 at 10:48
    
@SamHocevar I'm not sure, good question. My /etc/locale.conf contains LANG="en_GB.UTF-8" and LC_COLLATE="C". I use the UK English locale with a custom dvp layout. –  Attila O. May 18 at 4:21

1 Answer 1

up vote 2 down vote accepted

This is likely caused by GTK+, namely bug 705168. GTK+ overrides the X11 compose rules so whatever you may have in /usr/share/X11/locale will be ignored by default.

You can patiently wait for the bug to be fixed, but I would suggest switching to the X input method instead. This will ensure that GTK+ applications use the same input method as all other applications and properly parse your locale’s Compose rules. It is as simple as adding the line export GTK_IM_MODULE='xim' in your ~/.xprofile file.

share|improve this answer
    
Thanks @SamHocevar. I've started another bounty so that I can award you, but you'll have to wait the minimum one day before I can award it. –  Attila O. May 18 at 13:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.