Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(1) After cloning my root partition to an SSD and breaking and fixing things a number of times along the way, my system no longer shows the outputs from the rc-scripts on the console during boot. I can see the kernel messages (the things dmesg would show me) though.

(2) To diagnoese the problem I tried to boot directly into bash by providing init=/bin/bash at the boot prompt. But this doesn't work. I see a message "bash: cannot set terminal process group (-1). Inappropriate ioctl for device". And there is never a bash prompt. If I use "sash" I don't see this error, but a welcome message and still no prompt-

(3) The stranges thing is that adding "S" to the label at lilo's boot prompt used to boot into single-user-mode. This no longer works: it boots into runlevel 3 (at least it starts the display manager). Adding "1" however does work.

I believe there in one thing these issues have in common: something is wrong with my console. This explains why (1) the messages are not shown. Booting into a shell (2) also requires a terminal, and I believe suloging which is invoked when going single user (3) also needs one.

Otherwise the system runs fine. Any ideas how I could proceed to diagnose this?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.