Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a VirtualBox VM on all of my colleagues machines, one of which is giving weird problems - The VirtualBox installer doesn't seem to have installed it's network adapter/services.

It turns out, he doesn't have a certain access permission that the rest of us do, and it is preventing VirtualBox from programmatically allowing adapter installation. It also manifests itself as not allowing us to manually install a network service on his machine. He has, according to our sysadmin, the same user profile as the rest of the team, which gives admin rights.

Following the steps below, I am able to install a service to a network adapter (or at least open the selection window):

Control Panel > By Category > Network and Internet: View network status and tasks > Change adapter settings > Local Area Connection: Right click to properties > Install > Select "Service" > Click "Add" ... ... ...

On my machine, I have a window pop up "Select network service" On my colleague's machine, He has an access denied error message.

I can supply screenshots if required (or logs if there is a specified location), but I am not currently at his machine.

So, my question: How do I find out where this permission is set, and change it? Are there any areas on the filesystem or in the registry that may affect permissions here?

Many thanks, Mitch.

edit:

Thanks to an update on the virtual box forums, I have also tried to set the driver signature enforcement. This hasn't had any effect on the virtual box driver installation either, although I'm not too surprised as the manual steps listed above don't actually select anything that may have an (in)valid driver, it is prevented before we get that far...

share|improve this question
    
Is the user a member of the "Network Configuration Operators" group (look in lusrmgr.msc). –  ultrasawblade May 2 '14 at 16:21
    
Apologies @ultrasawblade - I've been away. He is not, but neither am I. Thanks... –  Mitch Kent May 12 '14 at 15:46
    
Add the user to that group and see if that resolves. –  ultrasawblade May 12 '14 at 16:20
    
Many thanks @ultrasawblade, however this didn't have any affect. –  Mitch Kent May 13 '14 at 10:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.